summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/golang-web.scm27
-rw-r--r--gnu/packages/golang.scm25
2 files changed, 26 insertions, 26 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index d021be005f..2790e2b5aa 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -5,9 +5,9 @@
;;; Copyright © 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2020 Ryan Prior <rprior@protonmail.com>
+;;; Copyright © 2020-2022 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
-;;; Copyright © 2021, 2022 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2022 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2022 jgart via Guix-patches via <guix-patches@gnu.org>
;;; Copyright © 2022 muradm <mail@muradm.net>
@@ -310,6 +310,31 @@ metrics (i.e. response time, bytes written, and http status code) from your
application's http.Handlers.")
(license license:expat)))
+(define-public go-github-com-francoispqt-gojay
+ (package
+ (name "go-github-com-francoispqt-gojay")
+ (version "1.2.13")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/francoispqt/gojay")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1ix95qdyajfmxhf9y52vjrih63f181pjs4v5as8905s4d5vmkd06"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/francoispqt/gojay"))
+ (propagated-inputs
+ (list go-github-com-stretchr-testify))
+ (synopsis "JSON encoder/decoder with powerful stream API for Golang")
+ (description "GoJay is a performant JSON encoder/decoder for Golang. It has
+a simple API and doesn't use reflection. It relies on small interfaces to
+decode/encode structures and slices.")
+ (home-page "https://github.com/francoispqt/gojay")
+ (license license:expat)))
+
(define-public go-github-com-go-chi-chi-v5
(package
(name "go-github-com-go-chi-chi-v5")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 40ffc1143d..beb14e0c3f 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -7479,31 +7479,6 @@ designed to clean up raw terminal output by stripping escape sequences,
optionally preserving color.")
(license license:expat)))
-(define-public go-github-com-francoispqt-gojay
- (package
- (name "go-github-com-francoispqt-gojay")
- (version "1.2.13")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/francoispqt/gojay")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1ix95qdyajfmxhf9y52vjrih63f181pjs4v5as8905s4d5vmkd06"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/francoispqt/gojay"))
- (propagated-inputs
- (list go-github-com-stretchr-testify))
- (synopsis "JSON encoder/decoder with powerful stream API for Golang")
- (description "GoJay is a performant JSON encoder/decoder for Golang. It has
-a simple API and doesn't use reflection. It relies on small interfaces to
-decode/encode structures and slices.")
- (home-page "https://github.com/francoispqt/gojay")
- (license license:expat)))
-
(define-public go-github-com-pkg-errors
(package
(name "go-github-com-pkg-errors")