summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/ocaml.scm16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 97bf7485b6..60cb47b369 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1648,6 +1648,22 @@ to be accepted by Jenkins.")
;; with OCaml linking exception
(license license:gpl3+)))
+(define-public ocaml-junit-alcotest
+ (package
+ (inherit ocaml-junit)
+ (name "ocaml-junit-alcotest")
+ (propagated-inputs (list ocaml-odoc ocaml-alcotest ocaml-junit))
+ (build-system dune-build-system)
+ (arguments
+ `(#:package "junit_alcotest"
+ #:tests? #f)); tests fail
+ (properties `((upstream-name . "junit_alcotest")))
+ (synopsis "JUnit XML reports generation for alcotest tests")
+ (description "This package generates JUnit XML reports from ocaml-alcotest
+test suites.")
+ ;; with OCaml linking exception
+ (license license:gpl3+)))
+
(define-public camlzip
(package
(name "camlzip")