summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/check.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 721cdf8e68..a7d90a2d7d 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -3273,7 +3273,11 @@ allowing you to declaratively define \"match\" rules.")
(sha256
(base32 "0sxb3835nly1jxn071f59fwbdzmqi74j040r81fanxyw3s1azw0i"))))
(arguments
- `(#:tests? #f)) ; It's run after build automatically.
+ (list
+ #:tests? #f ; It's run after build automatically.
+ ;; Fix 'Version:' setting in .pc file. See:
+ ;; <https://github.com/unittest-cpp/unittest-cpp/pull/188>
+ #:configure-flags #~(list (string-append "-DPACKAGE_VERSION=" #$version))))
(build-system cmake-build-system)
(home-page "https://github.com/unittest-cpp/unittest-cpp")
(synopsis "Lightweight unit testing framework for C++")