summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/autotools.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/autotools.scm b/gnu/packages/autotools.scm
index a46ac09228..9d4e7718d2 100644
--- a/gnu/packages/autotools.scm
+++ b/gnu/packages/autotools.scm
@@ -485,12 +485,14 @@ Makefile, simplifying the entire process for the developer.")
#:phases
(modify-phases %standard-phases
(add-before 'check 'pre-check
- (lambda* (#:key inputs native-inputs #:allow-other-keys)
+ (lambda* (#:key inputs native-inputs parallel-tests? #:allow-other-keys)
;; Run the test suite in parallel, if possible.
(setenv "TESTSUITEFLAGS"
(string-append
"-j"
- (number->string (parallel-job-count))))
+ (if parallel-tests?
+ (number->string (parallel-job-count))
+ "1")))
;; Patch references to /bin/sh.
(let ((bash (assoc-ref (or native-inputs inputs) "bash")))
(substitute* "tests/testsuite"