summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/samba.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/samba.scm b/gnu/packages/samba.scm
index bf92b210c3..2d1ea5959d 100644
--- a/gnu/packages/samba.scm
+++ b/gnu/packages/samba.scm
@@ -397,6 +397,14 @@ destructors. It is the core memory allocator used in Samba.")
(arguments
'(#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'remove-crypt-reference
+ ;; The following is needed because Python.h propagates
+ ;; HAVE_CRYPT_H, which is then seen from lib/replace/ but talloc
+ ;; doesn't need it at all.
+ (lambda _
+ (substitute* "lib/replace/replace.h"
+ (("#include <crypt.h>")
+ ""))))
(replace 'configure
;; tevent uses a custom configuration script that runs waf.
(lambda* (#:key outputs #:allow-other-keys)