summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/gnome.scm4
-rw-r--r--gnu/packages/gtk.scm23
-rw-r--r--gnu/packages/webkit.scm8
3 files changed, 24 insertions, 11 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 489f23865b..35491c3df2 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -4511,7 +4511,7 @@ passwords in the GNOME keyring.")
(define-public vala
(package
(name "vala")
- (version "0.56.14")
+ (version "0.56.16")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/vala/"
@@ -4519,7 +4519,7 @@ passwords in the GNOME keyring.")
"vala-" version ".tar.xz"))
(sha256
(base32
- "0mzmldhf6474dp2jkxj160kkafdz32c2l5f8xnm05p4vr9lc50lk"))))
+ "16yaiff5nl2dfyvs3bj8y7wvzh9riz6wqlx7csgg1lpm01b7nj05"))))
(build-system glib-or-gtk-build-system)
(arguments
(list
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index b0098e780e..d5ebd3df34 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -1128,7 +1128,7 @@ application suites.")
(define-public gtk
(package
(name "gtk")
- (version "4.12.3")
+ (version "4.14.2")
(source
(origin
(method url-fetch)
@@ -1136,7 +1136,7 @@ application suites.")
(version-major+minor version) "/"
name "-" version ".tar.xz"))
(sha256
- (base32 "128ahzsj016vz8brd8kplhfkxg2q7wy7kndibx2qfr68yrif530l"))
+ (base32 "0wp0w259rkwf6g8sk2b9jkms47vx5gp7mfs345grx9wq53plqq12"))
(patches
(search-patches "gtk4-respect-GUIX_GTK4_PATH.patch"))
(modules '((guix build utils)))))
@@ -1208,7 +1208,16 @@ application suites.")
;; This test, 'gtk:tools / validate', started failing for
;; unknown reasons after updating mesa to 23.3.1 and xorgproto
;; to 2023.2.
- ((" 'validate',") ""))
+ ((" 'validate',") "")
+ ;; XXX: These test failures come newly from 4.14.
+ ;; Not all of them are reported upstream yet, but the text nodes
+ ;; are mentioned in
+ ;; <https://gitlab.gnome.org/GNOME/gtk/-/issues/6647>.
+ (("'glyph-subpixel-position',") "")
+ (("'subpixel-positioning',") "")
+ (("'subpixel-positioning-hidpi-nogl-nocairo',") "")
+ (("'text.*\\.node',") "")
+ (("'text-mixed-color-colrv1',") ""))
(substitute* "testsuite/reftests/meson.build"
(("[ \t]*'label-wrap-justify.ui',") "")
;; The inscription-markup.ui fails due to /etc/machine-id
@@ -1276,6 +1285,7 @@ application suites.")
python-toml
python-typogrify
sassc ;for building themes
+ shaderc
tzdata-for-tests
vala
xorg-server-for-tests))
@@ -1897,7 +1907,7 @@ tutorial.")
(package
(inherit gtkmm)
(name "gtkmm")
- (version "3.24.8")
+ (version "3.24.9")
(source
(origin
(method url-fetch)
@@ -1906,7 +1916,7 @@ tutorial.")
(version-major+minor version) "/"
name "-" version ".tar.xz"))
(sha256
- (base32 "1i4ql0j6id6g34w5nbhd7vjak7l3s50lqgdjaj2ranrfj9j0r56j"))))
+ (base32 "1kj4mla3z9kxhdby5w88nl744xkmq6xchf79m1kfa72p0kjbzm9h"))))
(propagated-inputs
`(("atkmm-2.28" ,atkmm-2.28)
("cairomm-1.14" ,cairomm-1.14)
@@ -2424,6 +2434,9 @@ Parcellite and adds bugfixes and features.")
#:configure-flags
(list
"-Dinstalled_tests=false"
+ ;; Neon causes alignment faults, see
+ ;; <https://github.com/ebassi/graphene/issues/215>.
+ "-Darm_neon=false"
,@(if (%current-target-system)
;; Introspection requires running binaries for 'host' on 'build'.
'("-Dintrospection=disabled")
diff --git a/gnu/packages/webkit.scm b/gnu/packages/webkit.scm
index bf24a65e83..9b6f51d33c 100644
--- a/gnu/packages/webkit.scm
+++ b/gnu/packages/webkit.scm
@@ -127,13 +127,13 @@ engine that uses Wayland for graphics output.")
(define-public webkitgtk
(package
(name "webkitgtk")
- (version "2.42.5")
+ (version "2.44.1")
(source (origin
(method url-fetch)
(uri (string-append "https://www.webkitgtk.org/releases/"
name "-" version ".tar.xz"))
(sha256
- (base32 "0jg7c7z572afywwrnvdj3m5agaviv0vkqmzznnzzv30byb0phhmn"))
+ (base32 "0qamkk9db8m6x4qv5y10lihc18yzgrgbn6ldqw00ckghn1ci8ns2"))
(snippet
#~(begin
(use-modules (guix build utils))
@@ -322,13 +322,13 @@ propagated by default) such as @code{gst-plugins-good} and
(package
(inherit webkitgtk)
(name "wpewebkit")
- (version "2.40.5")
+ (version "2.44.1")
(source (origin
(inherit (package-source webkitgtk))
(uri (string-append "https://wpewebkit.org/releases/"
name "-" version ".tar.xz"))
(sha256
- (base32 "0cv74qy67a0hg8sba18wrjcmmwkj4z23wqnn5yqrh3n594q8srac"))))
+ (base32 "16y1gdz38d4b99b8zrvxy0nbrc70ih02ngi8090x7148rx7vz7rc"))))
(arguments
(substitute-keyword-arguments (package-arguments webkitgtk)
((#:configure-flags flags)