summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/diffoscope.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/diffoscope.scm b/gnu/packages/diffoscope.scm
index 3db52e5008..8106a6d258 100644
--- a/gnu/packages/diffoscope.scm
+++ b/gnu/packages/diffoscope.scm
@@ -139,6 +139,11 @@
(lambda _
;; This requires /sbin to be in $PATH.
(delete-file "tests/test_tools.py")))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ ;; Increase verbosity of tests and provide a summary
+ (invoke "pytest" "-vv" "-r" "sxX"))))
(add-after 'install 'install-man-page
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))