summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/ruby.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 24b5546ecf..f02ed79588 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -10152,9 +10152,11 @@ more complex, and error-prone.")
`(#:phases
(modify-phases %standard-phases
(replace 'check
- ;; Don't run tests to avoid circular dependence with rails. Instead
- ;; just import the library to test.
- (lambda _ (invoke "ruby" "-Ilib" "-r" "shoulda")))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ ;; Don't run tests to avoid circular dependence with rails.
+ ;; Instead just import the library to test.
+ (invoke "ruby" "-Ilib" "-r" "shoulda"))))
(add-after 'extract-gemspec 'relax-requirements
(lambda _
(substitute* "shoulda.gemspec"