summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/docbook.scm2
-rw-r--r--gnu/packages/maths.scm2
-rw-r--r--gnu/packages/python-xyz.scm4
-rw-r--r--gnu/packages/tex.scm36
4 files changed, 14 insertions, 30 deletions
diff --git a/gnu/packages/docbook.scm b/gnu/packages/docbook.scm
index 5e2f06b16c..4d85421d52 100644
--- a/gnu/packages/docbook.scm
+++ b/gnu/packages/docbook.scm
@@ -479,7 +479,7 @@ the in DocBook SGML DTDs.")
texlive-latex-pdfpages
texlive-refcount
texlive-subfigure
- texlive-latex-titlesec
+ texlive-titlesec
texlive-wasysym
texlive-fonts-rsfs
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index e0eaffac8d..be7bee22f2 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -5570,7 +5570,7 @@ set.")
texlive-latex-parskip
texlive-latex-stackengine
texlive-latex-tabulary
- texlive-latex-titlesec
+ texlive-titlesec
texlive-latex-tocloft
texlive-latex-upquote
texlive-latex-varwidth
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9c120879d2..6317f5cd98 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5856,7 +5856,7 @@ readable format.")
texlive-latex-preview
texlive-latex-tabulary
texlive-latex-threeparttable
- texlive-latex-titlesec
+ texlive-titlesec
texlive-latex-trimspaces
texlive-latex-ucs
texlive-latex-upquote
@@ -8941,7 +8941,7 @@ computing.")
texlive-latex-preview
texlive-latex-tabulary
texlive-latex-threeparttable
- texlive-latex-titlesec
+ texlive-titlesec
texlive-latex-trimspaces
texlive-latex-ucs
texlive-latex-upquote
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 6f31e9118c..b4724b693c 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6967,33 +6967,15 @@ The (currently) supported encodings are: OT1, T1, IL2, TS1, T2*, X2, QX, and
LGR. The package doesn't (currently) support mathematics.")
(license license:lppl)))
-(define-public texlive-latex-titlesec
+(define-public texlive-titlesec
(package
- (name "texlive-latex-titlesec")
- (version (number->string %texlive-revision))
- (source (origin
- (method svn-fetch)
- (uri (svn-reference
- (url (string-append "svn://www.tug.org/texlive/tags/"
- %texlive-tag "/Master/texmf-dist/"
- "/tex/latex/titlesec"))
- (revision %texlive-revision)))
- (file-name (string-append name "-" version "-checkout"))
- (sha256
- (base32
- "1kw7dvxvdfbf31zw0n8r0g5xak3vcdf25n33fqw93j59zpc5nvbl"))))
- (build-system trivial-build-system)
- (arguments
- `(#:modules ((guix build utils))
- #:builder
- (begin
- (use-modules (guix build utils))
- (let ((target (string-append (assoc-ref %outputs "out")
- "/share/texmf-dist/tex/latex/titlesec")))
- (mkdir-p target)
- (copy-recursively (assoc-ref %build-inputs "source") target)
- #t))))
- (home-page "https://www.ctan.org/pkg/titlesec")
+ (inherit
+ (simple-texlive-package
+ "texlive-titlesec"
+ (list "doc/latex/titlesec/" "tex/latex/titlesec/")
+ (base32 "01nwh4p15xblc3kgivjliihy9kr8yr2cqsf9wn2iwqv1njx0i2zw")
+ #:trivial? #t))
+ (home-page "https://ctan.org/macros/latex/contrib/titlesec")
(synopsis "Select alternative section titles")
(description
"This package provides an interface to sectioning commands for selection
@@ -7003,6 +6985,8 @@ styles. It also includes a package to change the page styles when there are
floats in a page. You may assign headers/footers to individual floats, too.")
(license license:lppl)))
+(define-deprecated-package texlive-latex-titlesec texlive-titlesec)
+
(define-public texlive-latex-type1cm
(package
(name "texlive-latex-type1cm")