summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/kde-frameworks.scm46
1 files changed, 46 insertions, 0 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 1b54285d77..90c7be6b50 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -29,6 +29,7 @@
#:use-module (gnu packages attr)
#:use-module (gnu packages boost)
#:use-module (gnu packages bison)
+ #:use-module (gnu packages boost)
#:use-module (gnu packages compression)
#:use-module (gnu packages databases)
#:use-module (gnu packages docbook)
@@ -1525,3 +1526,48 @@ gallons).")
maintaining an index of the contents of your files.")
;; dual licensed
(license (list license:gpl2+ license:lgpl2.1+))))
+
+(define-public kactivities
+ (package
+ (name "kactivities")
+ (version "5.24.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/frameworks/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0s8g43zk6h35bq1am1nnhj0qvmhd6kz42gs8l7ybga0367jghzhf"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)))
+ (inputs
+ `(("boost" ,boost)
+ ("kauth" ,kauth)
+ ("kbookmarks" ,kbookmarks)
+ ("kcodecs" ,kcodecs)
+ ("kcompletion" ,kcompletion)
+ ("kconfig" ,kconfig)
+ ("kconfigwidgets" ,kconfigwidgets)
+ ("kcoreaddons" ,kcoreaddons)
+ ("kio" ,kio)
+ ("kitemviews" ,kitemviews)
+ ("kjobwidgets" ,kjobwidgets)
+ ("kservice" ,kservice)
+ ("kwidgetsaddons" ,kwidgetsaddons)
+ ("kwindowsystem" ,kwindowsystem)
+ ("kxmlgui" ,kxmlgui)
+ ("qtbase" ,qtbase)
+ ("qtdeclarative" ,qtdeclarative)
+ ("solid" ,solid)))
+ (home-page "https://community.kde.org/Frameworks")
+ (synopsis "Core components for the KDE Activity concept")
+ (description "KActivities provides the infrastructure needed to manage a
+user's activites, allowing them to switch between tasks, and for applications
+to update their state to match the user's current activity. This includes a
+daemon, a library for interacting with that daemon, and plugins for integration
+with other frameworks.")
+ ;; triple licensed
+ (license (list license:gpl2+ license:lgpl2.0+ license:lgpl2.1+))))