summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/chemistry.scm7
-rw-r--r--gnu/packages/cran.scm2
-rw-r--r--gnu/packages/graphviz.scm2
-rw-r--r--gnu/packages/maths.scm2
-rw-r--r--gnu/packages/plotutils.scm2
-rw-r--r--gnu/packages/python-xyz.scm2
-rw-r--r--gnu/packages/sphinx.scm2
-rw-r--r--gnu/packages/tex.scm31
8 files changed, 27 insertions, 23 deletions
diff --git a/gnu/packages/chemistry.scm b/gnu/packages/chemistry.scm
index cddccf8aea..b97703e810 100644
--- a/gnu/packages/chemistry.scm
+++ b/gnu/packages/chemistry.scm
@@ -899,9 +899,10 @@ emphasis on quality rather than speed.")
(inputs (list openblas))
(native-inputs
(list gfortran
- (texlive-updmap.cfg (list texlive-fonts-ec
- texlive-graphics
- texlive-latex-geometry))))
+ (texlive-updmap.cfg
+ (list texlive-fonts-ec
+ texlive-geometry
+ texlive-graphics))))
(home-page "https://github.com/greglandrum/yaehmop")
(synopsis "Perform extended Hückel calculations")
(description "@acronym{YAeHMOP, Yet Another extended Hueckel Molecular
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 75ffc81bfd..4e3476222d 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -36197,7 +36197,7 @@ package online.")
texlive-iftex
texlive-fancyhdr
texlive-fancyvrb
- texlive-latex-geometry
+ texlive-geometry
texlive-graphics
texlive-latex-threeparttable
texlive-titlesec
diff --git a/gnu/packages/graphviz.scm b/gnu/packages/graphviz.scm
index 30dd6d3405..2f2a90461a 100644
--- a/gnu/packages/graphviz.scm
+++ b/gnu/packages/graphviz.scm
@@ -387,8 +387,8 @@ graphs in Graphviz's DOT language, written in pure Python.")
;; the resulting generated TeX files, which \usepackage them.
texlive-bin
texlive-amsmath
+ texlive-geometry
texlive-graphics
- texlive-latex-geometry
texlive-latex-base
texlive-latex-preview
texlive-latex-xkeyval
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 87b2b9816e..f8cd4f385b 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -5803,7 +5803,7 @@ set.")
texlive-latex-float
texlive-fncychap
texlive-framed
- texlive-latex-geometry
+ texlive-geometry
texlive-hanging
texlive-hyperref
texlive-latex-multirow
diff --git a/gnu/packages/plotutils.scm b/gnu/packages/plotutils.scm
index 57517c5bd2..20b08a74c2 100644
--- a/gnu/packages/plotutils.scm
+++ b/gnu/packages/plotutils.scm
@@ -311,7 +311,7 @@ colors, styles, options and details.")
texlive-epsf
texlive-etoolbox
texlive-fonts-ec
- texlive-latex-geometry
+ texlive-geometry
texlive-graphics
texlive-grfext
texlive-hyperref
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0d2da17edc..100ad3647e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15187,7 +15187,7 @@ time.")
texlive-hyperref
texlive-fancyvrb
texlive-latex-float
- texlive-latex-geometry
+ texlive-geometry
texlive-latex-jknapltx
texlive-ms
texlive-latex-parskip
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index 42ddbade1e..df701f55f0 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -119,7 +119,7 @@
texlive-latex-float
texlive-fncychap
texlive-framed
- texlive-latex-geometry
+ texlive-geometry
texlive-graphics ;graphicx, color
texlive-kvoptions
texlive-latex-needspace
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 3b1145d667..dbda741838 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6017,22 +6017,23 @@ BibLaTeX, and is considered experimental.")
(define-deprecated-package texlive-latex-gcite texlive-gcite)
-(define-public texlive-latex-geometry
+(define-public texlive-geometry
(package
- (name "texlive-latex-geometry")
+ (name "texlive-geometry")
(version (number->string %texlive-revision))
- (source (origin
- (method svn-fetch)
- (uri (texlive-ref "latex" "geometry"))
- (file-name (string-append name "-" version "-checkout"))
- (sha256
- (base32
- "0a9nrmiwksnpa6iaapirqid974ai56qgin2n4h9mggy9v8gp7r71"))))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/geometry/"
+ "source/latex/geometry/"
+ "tex/latex/geometry/")
+ (base32
+ "09jwdrg4s1c0gqmx7s57byw5kc09cna3li85y9ix0vxa6f6iqzi1")))
(build-system texlive-build-system)
- (arguments '(#:tex-directory "latex/geometry"))
+ (outputs '("out" "doc"))
(propagated-inputs
- (list texlive-oberdiek ;for ifpdf
- texlive-graphics)) ;for keyval
+ (list texlive-atbegshi
+ texlive-graphics ;for keyval
+ texlive-iftex))
(home-page "https://www.ctan.org/pkg/geometry")
(synopsis "Flexible and complete interface to document dimensions")
(description
@@ -6040,11 +6041,13 @@ BibLaTeX, and is considered experimental.")
page layout, implementing auto-centering and auto-balancing mechanisms so that
the users have only to give the least description for the page layout. The
package knows about all the standard paper sizes, so that the user need not
-know what the nominal \"real\" dimensions of the paper are, just its standard
+know what the nominal real dimensions of the paper are, just its standard
name (such as a4, letter, etc.). An important feature is the package's
ability to communicate the paper size it's set up to the output.")
(license license:lppl)))
+(define-deprecated-package texlive-latex-geometry texlive-geometry)
+
(define-public texlive-latex-mdwtools
(package
(name "texlive-latex-mdwtools")
@@ -11730,7 +11733,7 @@ handle complex tests.")
texlive-hyperref
texlive-latex-base
texlive-cyrillic
- texlive-latex-geometry
+ texlive-geometry
(texlive-updmap.cfg ;fonts
(list texlive-cbfonts
texlive-lh