summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/guile.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 1d36e3ee2a..414aafaf26 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -603,8 +603,8 @@ GNU@tie{}Guile. Use the @code{(ice-9 readline)} module and call its
"1l7ik4q4zk7vq4m3gnwizc0b64b1mdr31hxqlzxs94xaf2lvi7s2"))))
(arguments
(substitute-keyword-arguments (package-arguments guile-2.2)
- ((#:phases phases '%standard-phases)
- `(modify-phases ,phases
+ ((#:phases phases)
+ #~(modify-phases #$phases
(replace 'bootstrap
(lambda _
;; Disable broken tests.
@@ -617,8 +617,7 @@ GNU@tie{}Guile. Use the @code{(ice-9 readline)} module and call its
(string-append "#;" m)))
(patch-shebang "build-aux/git-version-gen")
- (invoke "sh" "autogen.sh")
- #t))))))
+ (invoke "sh" "autogen.sh")))))))
(native-inputs
(modify-inputs (package-native-inputs guile-2.2)
(prepend autoconf