summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/maths.scm2
-rw-r--r--gnu/packages/sphinx.scm4
-rw-r--r--gnu/packages/tex.scm40
3 files changed, 18 insertions, 28 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index c342965816..f9d16b9c99 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -5801,7 +5801,7 @@ set.")
texlive-latex-cmap
texlive-latex-colortbl
texlive-latex-float
- texlive-latex-fncychap
+ texlive-fncychap
texlive-latex-framed
texlive-latex-geometry
texlive-hanging
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index 65b3dc4ec5..58957c44bb 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -10,7 +10,7 @@
;;; Copyright © 2017 Christine Lemmer-Webber <cwebber@dustycloud.org>
;;; Copyright © 2017 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2019, 2021, 2022 Efraim Flashner <efraim@flashner.co.il>
-;;; Copyright © 2019, 2021 Nicolas Goaziou <mail@nicolasgoaziou.fr>
+;;; Copyright © 2019, 2021, 2023 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2019 Alexandros Theodotou <alex@zrythm.org>
;;; Copyright © 2019 Brett Gilio <brettg@gnu.org>
;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
@@ -117,7 +117,7 @@
texlive-fancyhdr
texlive-fancyvrb
texlive-latex-float
- texlive-latex-fncychap
+ texlive-fncychap
texlive-latex-framed
texlive-latex-geometry
texlive-graphics ;graphicx, color
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 8f7f1fa42f..5849f4f8d8 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5880,33 +5880,21 @@ of the LaTeX kernel.")
(define-deprecated-package texlive-latex-etoolbox texlive-etoolbox)
-(define-public texlive-latex-fncychap
+(define-public texlive-fncychap
(package
- (name "texlive-latex-fncychap")
+ (name "texlive-fncychap")
(version (number->string %texlive-revision))
- (source (origin
- (method svn-fetch)
- (uri (svn-reference
- (url (string-append "svn://www.tug.org/texlive/tags/"
- %texlive-tag "/Master/texmf-dist/"
- "/tex/latex/fncychap"))
- (revision %texlive-revision)))
- (file-name (string-append name "-" version "-checkout"))
- (sha256
- (base32
- "0fdk84dbicfjfprkz6vk15x36mvlhaw9isjmgkc56jp2khwjswwq"))))
- (build-system trivial-build-system)
- (arguments
- `(#:modules ((guix build utils))
- #:builder
- (begin
- (use-modules (guix build utils))
- (let ((target (string-append (assoc-ref %outputs "out")
- "/share/texmf-dist/tex/latex/fncychap")))
- (mkdir-p target)
- (copy-recursively (assoc-ref %build-inputs "source") target)
- #t))))
- (home-page "https://www.ctan.org/pkg/fncychap")
+ (source (texlive-origin
+ name version
+ (list "doc/latex/fncychap/"
+ "tex/latex/fncychap/")
+ (base32
+ "1javlws18ncrf7rz7qfbx1db9jwk45lm6sa0s67hlr6hqnyjxf94")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (propagated-inputs
+ (list texlive-graphics))
+ (home-page "https://ctan.org/pkg/fncychap")
(synopsis "Seven predefined chapter heading styles")
(description
"This package provides seven predefined chapter heading styles. Each
@@ -5915,6 +5903,8 @@ modify the formatting routines in order to create additional chapter
headings.")
(license license:lppl1.3+)))
+(define-deprecated-package texlive-latex-fncychap texlive-fncychap)
+
(define-public texlive-latex-framed
(package
(name "texlive-latex-framed")