summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python-xyz.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 2dfffe15df..3a7e85bcf9 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -27643,7 +27643,8 @@ decisions with any given backend.")
(list
;; Avoid coverage
#:test-flags
- #~(list "-m" "not gpu and not slow and not network"
+ #~(list "-n" "auto"
+ "-m" "not gpu and not slow and not network"
"-k" (string-append
;; This one cannot be interrupted.
"not test_interrupt"
@@ -27696,7 +27697,10 @@ parentdir_prefix = dask-
python-pyyaml))
(native-inputs
(list python-importlib-metadata
- python-pytest python-pytest-runner python-pytest-rerunfailures
+ python-pytest
+ python-pytest-rerunfailures
+ python-pytest-runner
+ python-pytest-xdist
python-versioneer))
(home-page "https://github.com/dask/dask/")
(synopsis "Parallel computing with task scheduling")