summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/llvm.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index 7aab2ae8c3..55ad9b96f7 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -1434,7 +1434,15 @@ Library.")
(package
(inherit llvm-15)
(version "17.0.6")
- (source (llvm-monorepo version))))
+ (source (llvm-monorepo version))
+ (arguments
+ (substitute-keyword-arguments (package-arguments llvm-15)
+ ;; The build daemon goes OOM on i686-linux on this phase.
+ ((#:phases phases #~'%standard-phases)
+ (if (target-x86-32?)
+ #~(modify-phases #$phases
+ (delete 'make-dynamic-linker-cache))
+ phases))))))
(define-public clang-runtime-17
(clang-runtime-from-llvm llvm-17))