summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python-xyz.scm13
1 files changed, 4 insertions, 9 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e4e09aa59b..d1fce8b505 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -11820,7 +11820,7 @@ WeightedLookup: A specialized RangeMap for selecting an item by weights.
(uri (pypi-uri "jaraco.context" version))
(sha256
(base32 "0hbjm1rpxf4pzmbdp9rh3ali4zqnlcr8m97bhh1nizxvzcpxim7h"))))
- (build-system python-build-system)
+ (build-system pyproject-build-system)
(arguments (list #:tests? #f))
(native-inputs (list python-setuptools-scm))
(home-page "https://github.com/jaraco/jaraco.context")
@@ -11837,14 +11837,9 @@ procedures.")
(package-arguments python-jaraco-context-bootstrap)
((#:tests? _ #f)
(not (%current-target-system)))
- ((#:phases phases #~%standard-phases)
- #~(modify-phases #$phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- ;; Do not test the myproject.toml build as it tries to pull
- ;; dependencies from the Internet.
- (invoke "pytest" "-vv" "-k" "not project"))))))))
+ ;; Do not test the myproject.toml build as it pulls dependencies.
+ ((#:test-flags test-flags '())
+ '(list "-k" "not project"))))
(native-inputs
(modify-inputs
(package-native-inputs python-jaraco-context-bootstrap)