summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/ocaml.scm24
1 files changed, 0 insertions, 24 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index f636ce0085..a8c497da95 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -7608,8 +7608,6 @@ that can later be used to manipulate time in core_kernel or core.")
(list ocaml-bisect-ppx ocaml-uchar ocaml-uutf ocaml-lwt))
(native-inputs
(list ocaml-ounit2 pkg-config))
- (properties
- `((ocaml4.07-variant . ,(delay (package-with-ocaml4.07 ocaml-markup0.8.0)))))
(synopsis "Error-recovering functional HTML5 and XML parsers and writers")
(description "Markup.ml provides an HTML parser and an XML parser. The
parsers are wrapped in a simple interface: they are functions that transform
@@ -7631,28 +7629,6 @@ a single pass. They automatically detect the character encoding of the input
stream, and convert everything to UTF-8.")
(license license:bsd-3)))
-;; ocaml-markup 1.0.0 can not be built with old version of dune used in
-;; package-with-ocaml4.07
-(define-public ocaml-markup0.8.0
- (package
- (inherit ocaml-markup)
- (name "ocaml-markup")
- (version "0.8.0")
- (home-page "https://github.com/aantron/markup.ml")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url (string-append home-page ".git"))
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0aif4abvfmi9xc1pvw5n5rbm6rzkkpsxyvdn0lanr33rjpvkwdlm"))))
- (native-inputs
- (list ocaml-ounit pkg-config))
- (properties '())))
-
(define-public ocaml-tyxml
(package
(name "ocaml-tyxml")