summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/sphinx.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index f5444e3331..5ec3695e85 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -1167,6 +1167,13 @@ enabled web server.")
documenting acceptable argument types and return value types of functions.")
(license license:expat)))
+(define-public python-sphinx-autodoc-typehints-5
+ (package/inherit python-sphinx-autodoc-typehints
+ (propagated-inputs
+ (modify-inputs
+ (package-propagated-inputs python-sphinx-autodoc-typehints)
+ (replace "python-sphinx" python-sphinx-5)))))
+
(define-public python-sphinx-pytest
(package
(name "python-sphinx-pytest")