summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/perl6.scm25
1 files changed, 13 insertions, 12 deletions
diff --git a/gnu/packages/perl6.scm b/gnu/packages/perl6.scm
index 98631e7843..ab6e1759b0 100644
--- a/gnu/packages/perl6.scm
+++ b/gnu/packages/perl6.scm
@@ -464,27 +464,28 @@ of the same class using @code{JSON::Unmarshal}.")
(define-public perl6-json-name
(package
(name "perl6-json-name")
- (version "0.0.3")
+ (version "0.0.6")
(source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/jonathanstowe/JSON-Name")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "130qwdpbj5qdlsdz05y0rksd79lzbq79scy47n6lnf21b0hz1qjc"))))
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jonathanstowe/JSON-Name")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0fbwp3av4kh7zlbrmgbka4x6s3d6fsw2qxafi9hyq0y896wsaf94"))))
(build-system rakudo-build-system)
(arguments '(#:with-zef? #f))
+ (propagated-inputs
+ (list perl6-json-optin))
(home-page "https://github.com/jonathanstowe/JSON-Name")
- (synopsis "Provides a trait to store an alternative JSON Name")
+ (synopsis "Provide a trait to store an alternative JSON name")
(description "This is released as a dependency of @code{JSON::Marshal} and
@code{JSON::Unmarshal} in order to save duplication, it is intended to store a
separate JSON name for an attribute where the name of the JSON attribute might be
changed, either for aesthetic reasons or the name is not a valid Perl identifier.
It will of course also be needed in classes thar are going to use
-@code{JSON::Marshal} or @code{JSON::Unmarshal} for serialisation/de-serialisation.")
+@code{JSON::Marshal} or @code{JSON::Unmarshal} for serialization/deserialization.")
(license license:artistic2.0)))
(define-public perl6-json-optin