summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/c.scm6
-rw-r--r--gnu/packages/patches/tinydir-fix-cbehave-test.patch16
2 files changed, 17 insertions, 5 deletions
diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
index 1346605c71..b558145ea0 100644
--- a/gnu/packages/c.scm
+++ b/gnu/packages/c.scm
@@ -20,7 +20,7 @@
;;; Copyright © 2022 Antero Mejr <antero@mailbox.org>
;;; Copyright © 2023 zamfofex <zamfofex@twdb.moe>
;;; Copyright © 2023 Foundation Devices, Inc. <hello@foundationdevices.com>
-;;; Copyright © 2023 David Elsing <david.elsing@posteo.net>
+;;; Copyright © 2023, 2024 David Elsing <david.elsing@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1349,7 +1349,7 @@ performance concurrent systems developed in C99+.")
(define-public tinydir
(package
(name "tinydir")
- (version "1.2.5")
+ (version "1.2.6")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1358,7 +1358,7 @@ performance concurrent systems developed in C99+.")
(file-name (git-file-name name version))
(sha256
(base32
- "1nprgdfx4i8wzc1idw6chan4fjfa75b5ll8kghdc0q2278pny259"))
+ "143n6yabznxk032gv5g2k8glf0kzicarg9cx0714zsbfmzj8lr07"))
(patches (search-patches "tinydir-fix-cbehave-test.patch"))
(modules '((guix build utils)))
(snippet '(delete-file-recursively "tests/cbehave"))))
diff --git a/gnu/packages/patches/tinydir-fix-cbehave-test.patch b/gnu/packages/patches/tinydir-fix-cbehave-test.patch
index 84ecee12c2..1cad42c7a0 100644
--- a/gnu/packages/patches/tinydir-fix-cbehave-test.patch
+++ b/gnu/packages/patches/tinydir-fix-cbehave-test.patch
@@ -2,10 +2,22 @@ Make test work with upstream cbehave
(tinydir bundles a modified version)
diff --git a/tests/file_open_test.c b/tests/file_open_test.c
-index 3e659bc..9f6f88d 100644
+index 09b856e..92b13ca 100644
--- a/tests/file_open_test.c
+++ b/tests/file_open_test.c
-@@ -19,4 +19,7 @@ FEATURE(file_open, "File open")
+@@ -4,6 +4,11 @@
+ #include "cbehave.h"
+ #include "util.h"
+
++#define ASSERT(cond, ret) \
++if (!(cond)) {\
++ cbehave_feature_return(__FILE__, __LINE__, ret, _state); \
++ goto _feature_over; \
++}\
+
+ FEATURE(file_open, "File open")
+ SCENARIO("Open file in current directory")
+@@ -34,4 +39,7 @@ FEATURE(file_open, "File open")
SCENARIO_END
FEATURE_END