summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/hurd.scm19
1 files changed, 9 insertions, 10 deletions
diff --git a/gnu/packages/hurd.scm b/gnu/packages/hurd.scm
index 4064a9e2e8..f697694124 100644
--- a/gnu/packages/hurd.scm
+++ b/gnu/packages/hurd.scm
@@ -329,14 +329,14 @@ Hurd-minimal package which are needed for both glibc and GCC.")
"hurd-rumpdisk-no-hd.patch"))))
(version (package-version hurd-headers))
(arguments
- `(#:phases
+ `(#:tests? #f ;no "check" target
+ #:phases
(modify-phases %standard-phases
(add-after 'unpack 'prepare-addons
(lambda* (#:key native-inputs inputs #:allow-other-keys)
;; First we import the things we want from dde.
(for-each make-file-writable (find-files "."))
- (let ((dde (or (assoc-ref inputs "dde-sources")
- (assoc-ref native-inputs "dde-sources"))))
+ (let ((dde (assoc-ref (or native-inputs inputs) "dde-sources")))
(for-each (lambda (dir)
(copy-recursively
(string-append dde "/" dir ) dir))
@@ -466,13 +466,13 @@ exec ${system}/rc \"$@\"
#t)))
(add-after 'build 'build-libdde-linux
(lambda* (#:key inputs native-inputs #:allow-other-keys)
- (invoke (string-append (assoc-ref native-inputs "make")
+ (invoke (string-append (assoc-ref (or native-inputs inputs) "make")
"/bin/make")
;; XXX There can be a race condition because subdirs
;; aren't interdependent targets in the Makefile.
"-j1" "-C" "libdde_linux26"
(string-append "SHELL="
- (assoc-ref native-inputs "bash")
+ (assoc-ref (or native-inputs inputs) "bash")
"/bin/bash")
(string-append "CC="
,(cc-for-target)))))
@@ -483,12 +483,12 @@ exec ${system}/rc \"$@\"
(let* ((out (assoc-ref outputs "out"))
(datadir (string-append out "/share/hurd")))
;; Install libdde_linux26.
- (invoke (string-append (assoc-ref native-inputs "make")
+ (invoke (string-append (assoc-ref (or native-inputs inputs) "make")
"/bin/make")
"-C" "libdde_linux26" "install"
(string-append "SHELL="
- (assoc-ref native-inputs "bash")
- "/bin/bash")
+ (assoc-ref (or native-inputs inputs) "bash")
+ "/bin/bash")
(string-append "INSTALLDIR="
out
"/share/libdde_linux26/build/include"))
@@ -590,8 +590,7 @@ implementing them.")
(add-after 'unpack 'prepare-dde
(lambda* (#:key native-inputs inputs #:allow-other-keys)
(for-each make-file-writable (find-files "."))
- (let ((dde (or (assoc-ref inputs "dde-sources")
- (assoc-ref native-inputs "dde-sources"))))
+ (let ((dde (assoc-ref (or native-inputs inputs) "dde-sources")))
(for-each (lambda (dir)
(copy-recursively
(string-append dde "/" dir ) dir))