summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/make-bootstrap.scm13
1 files changed, 11 insertions, 2 deletions
diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index 2d7a97488d..40c1f82230 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -206,8 +206,17 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
(("^xz_LDADD =")
"xz_LDADD = -all-static"))
#t)))))))
- (gawk (package (inherit gawk)
- (source (origin (inherit (package-source gawk))
+ (gawk (package
+ (inherit gawk)
+ (source (origin
+ (inherit (package-source gawk))
+ (modules '((guix build utils)))
+ (snippet
+ ;; Do not build 'getopt.c' since that leads to a
+ ;; link failure due to duplicate symbols with
+ ;; 'libc.a'.
+ '(substitute* "support/Makefile.in"
+ (("getopt\\.\\$\\(OBJEXT\\)") "")))
(patches (cons (search-patch "gawk-shell.patch")
(origin-patches
(package-source gawk))))))