summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/libevent.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/libevent.scm b/gnu/packages/libevent.scm
index d807315906..680db44707 100644
--- a/gnu/packages/libevent.scm
+++ b/gnu/packages/libevent.scm
@@ -76,6 +76,15 @@ then add or remove events dynamically without having to change the event
loop.")
(license bsd-3)))
+(define-public libevent-with-openssl
+ (package/inherit libevent
+ (name "libevent-with-openssl")
+ (inputs (modify-inputs (package-inputs libevent)
+ (prepend openssl)))
+ (arguments
+ ;; This skips some of the tests which fail on armhf and aarch64.
+ '(#:configure-flags '("--disable-libevent-regress")))))
+
(define-public libev
(package
(name "libev")