summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/multiprecision.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/multiprecision.scm b/gnu/packages/multiprecision.scm
index bb68ea06bf..51ba21162c 100644
--- a/gnu/packages/multiprecision.scm
+++ b/gnu/packages/multiprecision.scm
@@ -470,9 +470,10 @@ number generators, public key cryptography and a plethora of other routines.")
"/lib/libtommath.a"))
#t))
(replace 'check
- (lambda* (#:key test-target make-flags #:allow-other-keys)
- (apply invoke "make" test-target make-flags)
- (invoke "sh" "test")))
+ (lambda* (#:key tests? test-target make-flags #:allow-other-keys)
+ (when tests?
+ (apply invoke "make" test-target make-flags)
+ (invoke "sh" "test"))))
(add-after 'install 'install-static-library
(lambda* (#:key outputs #:allow-other-keys)
(invoke "make" "-f" "makefile.unix" "install"