summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/golang.scm38
-rw-r--r--gnu/packages/password-utils.scm29
2 files changed, 38 insertions, 29 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index d49c0d8ff6..1bda197324 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -8366,6 +8366,44 @@ configuration languages, but other uses may be possible too.")
(description "This package implements a low-level key/value store in Go.")
(license license:expat)))
+(define-public go-filippo-io-age
+ (package
+ (name "go-filippo-io-age")
+ (version "1.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/FiloSottile/age")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "19fz68n262kvg2ssw4r6nik30zk6g6cy7rdi0fm05czwigqrdz1i"))))
+ (build-system go-build-system)
+ (arguments `(#:import-path "filippo.io/age"))
+ (inputs
+ (list go-golang-org-x-sys
+ go-golang-org-x-term
+ go-golang-org-x-crypto
+ go-filippo-io-edwards25519))
+ (home-page "https://filippo.io/age")
+ (synopsis "Secure file encryption tool, format, and Go library")
+ (description
+ "This package implements file encryption according to the
+@{age-encryption.org/v1, https://age-encryption.org/v1} specification.
+It features small explicit keys, no configuration options, and Unix-style
+composability.")
+ (license license:bsd-3)))
+
+(define-public age
+ (package
+ (inherit go-filippo-io-age)
+ (name "age")
+ (arguments
+ `(#:import-path "filippo.io/age/cmd/age"
+ #:unpack-path "filippo.io/age"
+ #:install-source? #f))))
+
(define-public go-filippo-io-edwards25519
(package
(name "go-filippo-io-edwards25519")
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index 9d5fd79c58..404f588502 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -116,35 +116,6 @@
#:use-module (gnu packages xorg)
#:use-module (gnu packages xml))
-(define-public age
- (package
- (name "age")
- (version "1.0.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/FiloSottile/age")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "19fz68n262kvg2ssw4r6nik30zk6g6cy7rdi0fm05czwigqrdz1i"))))
- (build-system go-build-system)
- (arguments `(#:import-path "filippo.io/age"))
- (inputs
- (list go-golang-org-x-sys
- go-golang-org-x-term
- go-golang-org-x-crypto
- go-filippo-io-edwards25519))
- (home-page "https://filippo.io/age")
- (synopsis "Secure file encryption tool, format, and Go library")
- (description
- "This package implements file encryption according to the
-@{age-encryption.org/v1, https://age-encryption.org/v1} specification.
-It features small explicit keys, no configuration options, and Unix-style
-composability.")
- (license license:bsd-3)))
-
(define-public pwgen
(package
(name "pwgen")