summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/golang-check.scm28
-rw-r--r--gnu/packages/golang.scm28
2 files changed, 28 insertions, 28 deletions
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index 011198231d..56f412224e 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -458,6 +458,34 @@ such as readers and writers that fail after N consecutive reads/writes.")
custom assertions to be used alongside native Go testing.")
(license license:expat)))
+(define-public go-golang-org-x-lint
+ (let ((commit "83fdc39ff7b56453e3793356bcff3070b9b96445")
+ (revision "0"))
+ (package
+ (name "go-golang-org-x-lint")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://go.googlesource.com/lint")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0ms3rs5hvpnm9bxbr5f9743i7hn2bbmqdmvzxq6nmi0f24ypv1l3"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "golang.org/x/lint"
+ #:tests? #f)) ;; TODO: Fix tests
+ (propagated-inputs
+ (list go-golang-org-x-tools))
+ (home-page "https://golang.org/x/lint")
+ (synopsis "Linter for Go source code")
+ (description
+ "This is a linter for Go source code. Unlike gofmt, it doesn't
+reformat the source code, it only prints out style mistakes.")
+ (license license:bsd-3))))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 2503fca0b6..e5dd116766 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -11477,34 +11477,6 @@ be used as both a binary and a library.")
(native-inputs '())
(inputs '())))
-(define-public go-golang-org-x-lint
- (let ((commit "83fdc39ff7b56453e3793356bcff3070b9b96445")
- (revision "0"))
- (package
- (name "go-golang-org-x-lint")
- (version (git-version "0.0.0" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://go.googlesource.com/lint")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0ms3rs5hvpnm9bxbr5f9743i7hn2bbmqdmvzxq6nmi0f24ypv1l3"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "golang.org/x/lint"
- #:tests? #f)) ;; TODO: Fix tests
- (propagated-inputs
- (list go-golang-org-x-tools))
- (home-page "https://golang.org/x/lint")
- (synopsis "Linter for Go source code")
- (description
- "This is a linter for Go source code. Unlike gofmt, it doesn't
-reformat the source code, it only prints out style mistakes.")
- (license license:bsd-3))))
-
(define-public go-github-com-kisielk-gotool
(package
(name "go-github-com-kisielk-gotool")