summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/check.scm25
-rw-r--r--gnu/packages/golang-check.scm25
2 files changed, 25 insertions, 25 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 1f4c69cf99..4f593cde8d 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -898,31 +898,6 @@ prevent common NGINX misconfigurations. It provides the @command{gixy}
command.")
(license license:mpl2.0))))
-(define-public go-github.com-smartystreets-goconvey
- (package
- (name "go-github.com-smartystreets-goconvey")
- (version "1.6.3")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/smartystreets/goconvey")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1ph18rkl3ns3fgin5i4j54w5a69grrmf3apcsmnpdn1wlrbs3dxh"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/smartystreets/goconvey"))
- (propagated-inputs
- (list go-github.com-jtolds-gls go-github.com-smartystreets-assertions))
- (synopsis "Go testing tool with both a web and terminal user interface")
- (description
- "GoConvey is a testing tool for Go. It integrates with go test, can show
-test coverage and has a web user interface that will refresh automatically.")
- (home-page "https://github.com/smartystreets/goconvey")
- (license license:expat)))
-
(define-public googletest
(package
(name "googletest")
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index 0c37849806..c7b6e94791 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -412,6 +412,31 @@ Gomega matcher library.")
functions for writing tests in Go.")
(license license:expat)))
+(define-public go-github.com-smartystreets-goconvey
+ (package
+ (name "go-github.com-smartystreets-goconvey")
+ (version "1.6.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/smartystreets/goconvey")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1ph18rkl3ns3fgin5i4j54w5a69grrmf3apcsmnpdn1wlrbs3dxh"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/smartystreets/goconvey"))
+ (propagated-inputs
+ (list go-github.com-jtolds-gls go-github.com-smartystreets-assertions))
+ (home-page "https://github.com/smartystreets/goconvey")
+ (synopsis "Go testing tool with both a web and terminal user interface")
+ (description "GoConvey is a testing tool for Go. It integrates with go
+test, can show test coverage and has a web user interface that will refresh
+automatically.")
+ (license license:expat)))
+
(define-public go-github.com-smartystreets-gunit
(package
(name "go-github.com-smartystreets-gunit")