summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/golang.scm1
-rw-r--r--gnu/packages/password-utils.scm29
2 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 345168577f..d49c0d8ff6 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -36,6 +36,7 @@
;;; Copyright © 2022 Pier-Hugues Pellerin <phpellerin@gmail.com>
;;; Copyright © 2022 muradm <mail@muradm.net>
;;; Copyright © 2022 Dhruvin Gandhi <contact@dhruvin.dev>
+;;; Copyright © 2022 Nicolas Graves <ngraves@ngraves.fr>
;;;
;;; This file is part of GNU Guix.
;;;
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index fb17e426a7..df114aed7e 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -114,6 +114,35 @@
#:use-module (gnu packages xorg)
#:use-module (gnu packages xml))
+(define-public age
+ (package
+ (name "age")
+ (version "1.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/FiloSottile/age")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "19fz68n262kvg2ssw4r6nik30zk6g6cy7rdi0fm05czwigqrdz1i"))))
+ (build-system go-build-system)
+ (arguments `(#:import-path "filippo.io/age"))
+ (inputs
+ (list go-golang-org-x-sys
+ go-golang-org-x-term
+ go-golang-org-x-crypto
+ go-filippo-io-edwards25519))
+ (home-page "https://filippo.io/age")
+ (synopsis "Secure file encryption tool, format, and Go library")
+ (description
+ "This package implements file encryption according to the
+@{age-encryption.org/v1, https://age-encryption.org/v1} specification.
+It features small explicit keys, no configuration options, and Unix-style
+composability.")
+ (license license:bsd-3)))
+
(define-public pwgen
(package
(name "pwgen")