summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/bioinformatics.scm18
1 files changed, 9 insertions, 9 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index e579afe12d..485faefdc9 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -3037,15 +3037,15 @@ of these reads to align data quickly through a hash-based indexing scheme.")
'(#:tests? #f ;no check target
#:make-flags '("STAR")
#:phases
- (alist-cons-after
- 'unpack 'enter-source-dir (lambda _ (chdir "source"))
- (alist-replace
- 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((bin (string-append (assoc-ref outputs "out") "/bin/")))
- (install-file "STAR" bin)))
- (alist-delete
- 'configure %standard-phases)))))
+ (modify-phases %standard-phases
+ (add-after 'unpack 'enter-source-dir
+ (lambda _ (chdir "source") #t))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((bin (string-append (assoc-ref outputs "out") "/bin/")))
+ (install-file "STAR" bin))
+ #t))
+ (delete 'configure))))
(native-inputs
`(("vim" ,vim))) ; for xxd
(inputs