summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/make-bootstrap.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index c79bcc2cf3..2630ad5ce0 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -363,6 +363,11 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
(string-append incdir "/asm"))
(copy-recursively (string-append linux "/include/asm-generic")
(string-append incdir "/asm-generic"))
+
+ ;; Remove the '.install' and '..install.cmd' files; the latter
+ ;; contains store paths, which prevents bit reproducibility.
+ (for-each delete-file (find-files incdir "\\.install"))
+
#t))))
(inputs `(("libc" ,(let ((target (%current-target-system)))
(if target