summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/gcc.scm13
1 files changed, 12 insertions, 1 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index c368b7df97..957917bf0b 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -444,7 +444,18 @@ Go. It also includes runtime support libraries for these languages.")
(string-append jvm "/lib/tools.jar")))
(chmod target #o755)
#t))
- ,phases))))))
+ (alist-cons-after
+ 'install 'remove-broken-or-conflicting-files
+ (lambda _
+ (let ((out (assoc-ref %outputs "out")))
+ (for-each
+ delete-file
+ (append (find-files (string-append out "/lib/jvm/jre/lib")
+ "libjawt.so")
+ (find-files (string-append out "/bin")
+ ".*(c\\+\\+|cpp|g\\+\\+|gcc.*)"))))
+ #t)
+ ,phases)))))))
(define ecj-bootstrap-4.8
(origin