summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/gstreamer.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index e941f8b2a0..ad0cfccca9 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -176,6 +176,7 @@ This package provides the core library and elements.")
(native-inputs
`(("pkg-config" ,pkg-config)
("glib" ,glib "bin")
+ ("gobject-introspection" ,gobject-introspection)
("python-wrapper" ,python-wrapper)))
(arguments
`(#:configure-flags
@@ -184,10 +185,12 @@ This package provides the core library and elements.")
"/share/gtk-doc/html"))
#:phases
(alist-cons-before
- 'configure 'patch-test-pb-utils
+ 'configure 'patch
(lambda _
(substitute* "tests/check/libs/pbutils.c"
- (("/bin/sh") (which "sh"))))
+ (("/bin/sh") (which "sh")))
+ ;; for g-ir-scanner.
+ (setenv "CC" "gcc"))
%standard-phases)))
(home-page "http://gstreamer.freedesktop.org/")
(synopsis