summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/ocaml.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index f6bb9f7488..bcd4c196c5 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
+;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -47,7 +48,9 @@
;; OCaml uses "-prefix <prefix>" rather than the usual
;; "--prefix=<prefix>".
(let ((out (assoc-ref outputs "out")))
- (zero? (system* "./configure" "-prefix" out))))
+ (zero? (system* "./configure" "-prefix" out
+ "-mandir"
+ (string-append out "/share/man")))))
(alist-replace
'build
(lambda* (#:key outputs #:allow-other-keys)