summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu-system.am1
-rw-r--r--gnu/packages/mpd.scm48
2 files changed, 49 insertions, 0 deletions
diff --git a/gnu-system.am b/gnu-system.am
index 711687629e..f4b326553c 100644
--- a/gnu-system.am
+++ b/gnu-system.am
@@ -146,6 +146,7 @@ GNU_SYSTEM_MODULES = \
gnu/packages/maths.scm \
gnu/packages/mit-krb5.scm \
gnu/packages/moe.scm \
+ gnu/packages/mpd.scm \
gnu/packages/mp3.scm \
gnu/packages/multiprecision.scm \
gnu/packages/mtools.scm \
diff --git a/gnu/packages/mpd.scm b/gnu/packages/mpd.scm
new file mode 100644
index 0000000000..91a33a2001
--- /dev/null
+++ b/gnu/packages/mpd.scm
@@ -0,0 +1,48 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2014 David Thompson <dthompson2@worcester.edu>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages mpd)
+ #:use-module (gnu packages)
+ #:use-module (guix licenses)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system gnu)
+ #:export (libmpdclient))
+
+(define libmpdclient
+ (package
+ (name "libmpdclient")
+ (version "2.9")
+ (source (origin
+ (method url-fetch)
+ (uri
+ (string-append "http://musicpd.org/download/libmpdclient/"
+ (car (string-split version #\.))
+ "/libmpdclient-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0csb9r3nlmbwpiryixjr5k33x3zqd61xjhwmlps3a6prck1n1xw2"))))
+ (build-system gnu-build-system)
+ (arguments
+ ;; FIXME: Needs doxygen.
+ '(#:configure-flags '("--disable-documentation")))
+ (synopsis "Music Player Daemon client library")
+ (description "A stable, documented, asynchronous API library for
+interfacing MPD in the C, C++ & Objective C languages.")
+ (home-page "http://www.musicpd.org/libs/libmpdclient/")
+ (license bsd-3)))