summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/base.scm21
-rw-r--r--gnu/packages/bootstrap.scm4
-rw-r--r--gnu/packages/check.scm10
-rw-r--r--gnu/packages/cmake.scm5
-rw-r--r--gnu/packages/databases.scm4
-rw-r--r--gnu/packages/ed.scm16
-rw-r--r--gnu/packages/fonts.scm4
-rw-r--r--gnu/packages/glib.scm16
-rw-r--r--gnu/packages/image.scm4
-rw-r--r--gnu/packages/linux.scm4
-rw-r--r--gnu/packages/multiprecision.scm4
-rw-r--r--gnu/packages/python.scm77
-rw-r--r--gnu/packages/tls.scm4
-rw-r--r--gnu/packages/xdisorg.scm4
-rw-r--r--gnu/services/dbus.scm6
-rw-r--r--guix/build/gnu-build-system.scm2
16 files changed, 79 insertions, 106 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index e6628277a6..7bd2ba4121 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -74,14 +74,14 @@ command-line arguments, multiple languages, and so on.")
(define-public grep
(package
(name "grep")
- (version "2.22")
+ (version "2.24")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/grep/grep-"
version ".tar.xz"))
(sha256
(base32
- "1srn321x7whlhs5ks36zlcrrmj4iahll8fxwsh1vbz3v04px54fa"))
+ "057cir4p19h7yv4xir1wiaxfa1fp45d3pl7xsaaannlc16wvwj7j"))
(patches
(list (search-patch "grep-timing-sensitive-test.patch")))))
(build-system gnu-build-system)
@@ -245,23 +245,14 @@ used to apply commands with arbitrarily long arguments.")
(define-public coreutils
(package
(name "coreutils")
- (version "8.24")
+ (version "8.25")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/coreutils/coreutils-"
version ".tar.xz"))
(sha256
(base32
- "0w11jw3fb5sslf0f72kxy7llxgk1ia3a6bcw0c9kmvxrlj355mx2"))
- (patches
- (list (origin
- (method url-fetch)
- (uri "http://git.savannah.gnu.org/cgit/coreutils.git/\
-patch/?id=3ba68f9e64fa2eb8af22d510437a0c6441feb5e0")
- (sha256
- (base32
- "1dnlszhc8lihhg801i9sz896mlrgfsjfcz62636prb27k5hmixqz"))
- (file-name "coreutils-tail-inotify-race.patch"))))))
+ "11yfrnb94xzmvi4lhclkcmkqsbhww64wf234ya1aacjvg82prrii"))))
(build-system gnu-build-system)
(inputs `(("acl" ,acl) ; TODO: add SELinux
("gmp" ,gmp) ;bignums in 'expr', yay!
@@ -355,14 +346,14 @@ change. GNU make offers many powerful extensions over the standard utility.")
(define-public binutils
(package
(name "binutils")
- (version "2.25.1")
+ (version "2.26")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/binutils/binutils-"
version ".tar.bz2"))
(sha256
(base32
- "08lzmhidzc16af1zbx34f8cy4z7mzrswpdbhrb8shy3xxpflmcdm"))
+ "1ngc2h3knhiw8s22l8y6afycfaxr5grviqy7mwvm4bsl14cf9b62"))
(patches (list (search-patch "binutils-ld-new-dtags.patch")
(search-patch "binutils-loongson-workaround.patch")))))
(build-system gnu-build-system)
diff --git a/gnu/packages/bootstrap.scm b/gnu/packages/bootstrap.scm
index f5bf069c20..2cd8534ace 100644
--- a/gnu/packages/bootstrap.scm
+++ b/gnu/packages/bootstrap.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2014, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
;;;
;;; This file is part of GNU Guix.
@@ -61,7 +61,7 @@
(define (boot fetch)
(lambda* (url hash-algo hash
#:optional name #:key system)
- (fetch url hash-algo hash
+ (fetch url hash-algo hash name
#:guile %bootstrap-guile
#:system system)))
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 4db2e6c071..2b2dce9e9e 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -35,17 +35,17 @@
(define-public check
(package
(name "check")
- (version "0.9.14")
+ (version "0.10.0")
(source
(origin
(method url-fetch)
- (uri (string-append "mirror://sourceforge/check/check/"
- version "/check-" version ".tar.gz"))
+ (uri (string-append "https://github.com/libcheck/check/files/71408/"
+ "/check-" version ".tar.gz"))
(sha256
(base32
- "02l4g79d81s07hzywcv1knwj5dyrwjiq2pgxaz7kidxi8m364wn2"))))
+ "0lhhywf5nxl3dd0hdakra3aasl590756c9kmvyifb3vgm9k0gxgm"))))
(build-system gnu-build-system)
- (home-page "http://check.sourceforge.net/")
+ (home-page "https://libcheck.github.io/check/")
(synopsis "Unit test framework for C")
(description
"Check is a unit testing framework for C. It features a simple
diff --git a/gnu/packages/cmake.scm b/gnu/packages/cmake.scm
index d75b9f62ef..e8b292f862 100644
--- a/gnu/packages/cmake.scm
+++ b/gnu/packages/cmake.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2014 Ian Denhardt <ian@zenhack.net>
;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
+;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -36,7 +37,7 @@
(define-public cmake
(package
(name "cmake")
- (version "3.3.2")
+ (version "3.5.0")
(source (origin
(method url-fetch)
(uri (string-append "https://www.cmake.org/files/v"
@@ -44,7 +45,7 @@
"/cmake-" version ".tar.gz"))
(sha256
(base32
- "08pwy9ip9cgwgynhn5vrjw8drw29gijy1rmziq22n65zds6ifnp7"))
+ "1yly38mpk2s08b4rglp9xcw5pxalk0whp9hrcg7j8qpxlkc3mj4j"))
(patches (list (search-patch "cmake-fix-tests.patch")))))
(build-system gnu-build-system)
(arguments
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 6612e37aa0..71ad77b9be 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -340,7 +340,7 @@ types are supported, as is encryption.")
(define-public sqlite
(package
(name "sqlite")
- (version "3.10.0")
+ (version "3.11.1")
(source (origin
(method url-fetch)
;; TODO: Download from sqlite.org once this bug :
@@ -371,7 +371,7 @@ types are supported, as is encryption.")
))
(sha256
(base32
- "0hhhv6si0pyf5i8bv7a71953m0b4gk6s3j2h09caf7vif0njkk23"))))
+ "0xs3gl3kbxqfx2ahrymgcf2n8c8sy37724jr05pncbhw4z8g2gsk"))))
(build-system gnu-build-system)
(inputs `(("readline" ,readline)))
(arguments
diff --git a/gnu/packages/ed.scm b/gnu/packages/ed.scm
index 7cd1fcd71d..3668aac19a 100644
--- a/gnu/packages/ed.scm
+++ b/gnu/packages/ed.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -27,23 +28,24 @@
(define-public ed
(package
(name "ed")
- (version "1.12")
+ (version "1.13")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/ed/ed-"
version ".tar.lz"))
(sha256
(base32
- "0bw0187a311rci58vznvncsj6pfp8bhs5phrlrqn03sa2i1mfrfj"))))
+ "1ly7i1iw02vbcd0zrx084z577ngxnarffmkm45dg6vndad5carnd"))))
(build-system gnu-build-system)
(native-inputs `(("lzip" ,lzip)))
(arguments
'(#:configure-flags '("CC=gcc")
- #:phases (alist-cons-before 'patch-source-shebangs 'patch-test-suite
- (lambda _
- (substitute* "testsuite/check.sh"
- (("/bin/sh") (which "sh"))))
- %standard-phases)))
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'patch-source-shebangs 'patch-test-suite
+ (lambda _
+ (substitute* "testsuite/check.sh"
+ (("/bin/sh") (which "sh"))))))))
(home-page "http://www.gnu.org/software/ed/")
(synopsis "Line-oriented text editor")
(description
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index f07e052936..8aa5a0dc33 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -121,7 +121,7 @@ TrueType (TTF) files.")
(define-public font-dejavu
(package
(name "font-dejavu")
- (version "2.34")
+ (version "2.35")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/dejavu/"
@@ -129,7 +129,7 @@ TrueType (TTF) files.")
version ".tar.bz2"))
(sha256
(base32
- "0pgb0a3ngamidacmrvasg51ck3gp8gn93w6sf1s8snwzx4x2r9yh"))))
+ "122d35y93r820zhi6d7m9xhakdib10z51v63lnlg67qhhrardmzn"))))
(build-system trivial-build-system)
(arguments
`(#:modules ((guix build utils))
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index bc69af5a9e..16a1a6162d 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -61,14 +61,15 @@
(name "dbus")
(version "1.10.0")
(source (origin
- ;; TODO: Apply patch from DBUS/ACTIVATION below.
(method url-fetch)
(uri (string-append
"https://dbus.freedesktop.org/releases/dbus/dbus-"
version ".tar.gz"))
(sha256
(base32
- "0jwj7wlrhq5y0fwfh8k2d9rgdpfax06lj8698g6iqbwrzd2rgyqx"))))
+ "0jwj7wlrhq5y0fwfh8k2d9rgdpfax06lj8698g6iqbwrzd2rgyqx"))
+ (patches
+ (list (search-patch "dbus-helper-search-path.patch")))))
(build-system gnu-build-system)
(arguments
'(#:configure-flags
@@ -126,17 +127,6 @@ or through unencrypted TCP/IP suitable for use behind a firewall with
shared NFS home directories.")
(license license:gpl2+))) ; or Academic Free License 2.1
-(define-public dbus/activation
- ;; D-Bus with a patch to fix service activation.
- ;; TODO: Merge with DBUS above.
- (package
- (inherit dbus)
- (version (string-append (package-version dbus) ".a"))
- (source (origin
- (inherit (package-source dbus))
- (patches
- (list (search-patch "dbus-helper-search-path.patch")))))))
-
(define glib
(package
(name "glib")
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 0343e45d6f..2273e78d8a 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -376,14 +376,14 @@ error-resilience, a Java-viewer for j2k-images, ...")
(define-public giflib
(package
(name "giflib")
- (version "5.1.1")
+ (version "5.1.2")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/giflib/giflib-"
(first (string-split version #\.))
".x/giflib-" version ".tar.bz2"))
(sha256
- (base32 "1z1gzq16sdya8xnl5qjc07634kkwj5m0n3bvvj4v9j11xfn1841r"))))
+ (base32 "0z1adsza46q84chkxwr6x8ph11k117k8nywkzwar6bxhqf2a1h3n"))))
(build-system gnu-build-system)
(outputs '("bin" ; utility programs
"out")) ; library
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index f62c254447..53d13d5b57 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -99,7 +99,7 @@
version "-gnu.tar.xz")))
(define-public linux-libre-headers
- (let* ((version "3.14.37")
+ (let* ((version "4.1.18")
(build-phase
(lambda (arch)
`(lambda _
@@ -137,7 +137,7 @@
(uri (linux-libre-urls version))
(sha256
(base32
- "1blxr2bsvfqi9khj4cpspv434bmx252zak2wsbi2mgl60zh77gza"))))
+ "1bddh2rg645lavhjkk9z75vflba5y0g73z2fjwgbfrj5jb44x9i7"))))
(build-system gnu-build-system)
(native-inputs `(("perl" ,perl)))
(arguments
diff --git a/gnu/packages/multiprecision.scm b/gnu/packages/multiprecision.scm
index ad507706db..ba2211974b 100644
--- a/gnu/packages/multiprecision.scm
+++ b/gnu/packages/multiprecision.scm
@@ -81,13 +81,13 @@ cryptography and computational algebra.")
(define-public mpfr
(package
(name "mpfr")
- (version "3.1.3")
+ (version "3.1.4")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/mpfr/mpfr-" version
".tar.xz"))
(sha256 (base32
- "05jaa5z78lvrayld09nyr0v27c1m5dm9l7kr85v2bj4jv65s0db8"))))
+ "1x8pcnpn1vxfzfsr0js07rwhwyq27fmdzcfjpzi5773ldnqi653n"))))
(build-system gnu-build-system)
(outputs '("out" "debug"))
(propagated-inputs `(("gmp" ,gmp))) ; <mpfr.h> refers to <gmp.h>
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 97a69c3a1b..c2685f6055 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -89,7 +89,7 @@
(define-public python-2
(package
(name "python")
- (version "2.7.10")
+ (version "2.7.11")
(source
(origin
(method url-fetch)
@@ -97,56 +97,45 @@
version "/Python-" version ".tar.xz"))
(sha256
(base32
- "1h7zbrf9pkj29hlm18b10548ch9757f75m64l47sy75rh43p7lqw"))
+ "0iiz844riiznsyhhyy962710pz228gmhv8qi3yk4w4jhmx2lqawn"))
(patches (map search-patch
'("python-2.7-search-paths.patch"
"python-2-deterministic-build-info.patch"
- "python-2.7-source-date-epoch.patch")))))
+ "python-2.7-source-date-epoch.patch")))
+ (modules '((guix build utils)))
+ ;; suboptimal to delete failing tests here, but if we delete them in the
+ ;; arguments then we need to make sure to strip out that phase when it
+ ;; gets inherited by python and python-minimal.
+ (snippet
+ '(begin
+ (for-each delete-file
+ '("Lib/test/test_compileall.py"
+ "Lib/test/test_distutils.py"
+ "Lib/test/test_import.py"
+ "Lib/test/test_shutil.py"
+ "Lib/test/test_socket.py"
+ "Lib/test/test_subprocess.py"))
+ #t))))
(outputs '("out"
"tk")) ;tkinter; adds 50 MiB to the closure
(build-system gnu-build-system)
(arguments
- `(#:tests? #f
- ;; 268 tests OK.
- ;; 103 tests failed:
- ;; test_distutils test_shutil test_signal test_site test_slice
- ;; test_smtplib test_smtpnet test_socket test_socketserver
- ;; test_softspace test_sort test_spwd test_sqlite test_ssl
- ;; test_startfile test_stat test_str test_strftime test_string
- ;; test_stringprep test_strop test_strptime test_strtod test_struct
- ;; test_structmembers test_structseq test_subprocess test_sunau
- ;; test_sunaudiodev test_sundry test_symtable test_syntax test_sys
- ;; test_sys_setprofile test_sys_settrace test_sysconfig test_tarfile
- ;; test_tcl test_telnetlib test_tempfile test_textwrap test_thread
- ;; test_threaded_import test_threadedtempfile test_threading
- ;; test_threading_local test_threadsignals test_time test_timeit
- ;; test_timeout test_tk test_tokenize test_tools test_trace
- ;; test_traceback test_transformer test_ttk_guionly test_ttk_textonly
- ;; test_tuple test_typechecks test_ucn test_unary
- ;; test_undocumented_details test_unicode test_unicode_file
- ;; test_unicodedata test_univnewlines test_univnewlines2k test_unpack
- ;; test_urllib test_urllib2 test_urllib2_localnet test_urllib2net
- ;; test_urllibnet test_urlparse test_userdict test_userlist
- ;; test_userstring test_uu test_uuid test_wait3 test_wait4
- ;; test_warnings test_wave test_weakref test_weakset test_whichdb
- ;; test_winreg test_winsound test_with test_wsgiref test_xdrlib
- ;; test_xml_etree test_xml_etree_c test_xmllib test_xmlrpc
- ;; test_xpickle test_xrange test_zipfile test_zipfile64
- ;; test_zipimport test_zipimport_support test_zlib
- ;; 30 tests skipped:
+ `(;; 356 tests OK.
+ ;; 6 tests failed:
+ ;; test_compileall test_distutils test_import test_shutil test_socket
+ ;; test_subprocess
+ ;; 39 tests skipped:
;; test_aepack test_al test_applesingle test_bsddb test_bsddb185
;; test_bsddb3 test_cd test_cl test_codecmaps_cn test_codecmaps_hk
- ;; test_codecmaps_jp test_codecmaps_kr test_codecmaps_tw test_crypt
- ;; test_curses test_dl test_gdb test_gl test_idle test_imageop
- ;; test_imgfile test_ioctl test_kqueue test_linuxaudiodev test_macos
- ;; test_macostools test_msilib test_nis test_ossaudiodev
- ;; test_scriptpackages
- ;; 6 skips unexpected on linux2:
- ;; test_bsddb test_bsddb3 test_crypt test_gdb test_idle test_ioctl
- ;; One of the typical errors:
- ;; test_unicode
- ;; test test_unicode crashed -- <type 'exceptions.OSError'>: [Errno 2] No
- ;; such file or directory
+ ;; test_codecmaps_jp test_codecmaps_kr test_codecmaps_tw test_curses
+ ;; test_dl test_gdb test_gl test_imageop test_imgfile test_ioctl
+ ;; test_kqueue test_linuxaudiodev test_macos test_macostools
+ ;; test_msilib test_ossaudiodev test_scriptpackages test_smtpnet
+ ;; test_socketserver test_startfile test_sunaudiodev test_timeout
+ ;; test_tk test_ttk_guionly test_urllib2net test_urllibnet
+ ;; test_winreg test_winsound test_zipfile64
+ ;; 4 skips unexpected on linux2:
+ ;; test_bsddb test_bsddb3 test_gdb test_ioctl
#:test-target "test"
#:configure-flags
(list "--enable-shared" ;allow embedding
@@ -332,8 +321,8 @@ data types.")
(lambda (old new)
(symlink (string-append python old)
(string-append bin "/" new)))
- `("python3" ,"pydoc3" ,"idle3")
- `("python" ,"pydoc" ,"idle"))))))
+ '("python3" "pydoc3" "idle3")
+ '("python" "pydoc" "idle"))))))
(synopsis "Wrapper for the Python 3 commands")
(description
"This package provides wrappers for the commands of Python@tie{}3.x such
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index b6bf2578ea..74cb14c47c 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -107,7 +107,7 @@ living in the same process.")
(define-public gnutls
(package
(name "gnutls")
- (version "3.4.7")
+ (version "3.4.9")
(source (origin
(method url-fetch)
(uri
@@ -118,7 +118,7 @@ living in the same process.")
"/gnutls-" version ".tar.xz"))
(sha256
(base32
- "0nifi3mr5jhz608pidkp8cjs4vwfj1m2qczsjrgpnp99615rxgn1"))))
+ "0gvwyl0kdp1qpzbzp46wqfdzzrmwy9n54sgcjvvm1m1kpanlyna8"))))
(build-system gnu-build-system)
(arguments
'(#:configure-flags
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 5a77a6c8f3..7cb4f44ace 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -218,7 +218,7 @@ rasterisation.")
(define-public libdrm
(package
(name "libdrm")
- (version "2.4.65")
+ (version "2.4.67")
(source
(origin
(method url-fetch)
@@ -228,7 +228,7 @@ rasterisation.")
".tar.bz2"))
(sha256
(base32
- "1i4n7mz49l0j4kr0dg9n1j3hlc786ncqgj0v5fci1mz7pp40m5ki"))
+ "1gnf206zs8dwszvkv4z2hbvh23045z0q29kms127bqrv27hp2nzf"))
(patches (list (search-patch "libdrm-symbol-check.patch")))))
(build-system gnu-build-system)
(inputs
diff --git a/gnu/services/dbus.scm b/gnu/services/dbus.scm
index 88a840a4b5..cd1b5f4b8a 100644
--- a/gnu/services/dbus.scm
+++ b/gnu/services/dbus.scm
@@ -21,7 +21,7 @@
#:use-module (gnu services)
#:use-module (gnu services shepherd)
#:use-module (gnu system shadow)
- #:use-module ((gnu packages glib) #:select (dbus/activation))
+ #:use-module ((gnu packages glib) #:select (dbus))
#:use-module (gnu packages admin)
#:use-module (guix gexp)
#:use-module (guix records)
@@ -38,7 +38,7 @@
dbus-configuration make-dbus-configuration
dbus-configuration?
(dbus dbus-configuration-dbus ;<package>
- (default dbus/activation))
+ (default dbus))
(services dbus-configuration-services ;list of <package>
(default '())))
@@ -198,7 +198,7 @@ includes the @code{etc/dbus-1/system.d} directories of each package listed in
(append (dbus-configuration-services config)
services)))))))
-(define* (dbus-service #:key (dbus dbus/activation) (services '()))
+(define* (dbus-service #:key (dbus dbus) (services '()))
"Return a service that runs the \"system bus\", using @var{dbus}, with
support for @var{services}.
diff --git a/guix/build/gnu-build-system.scm b/guix/build/gnu-build-system.scm
index 2abaa6efdc..34edff7f40 100644
--- a/guix/build/gnu-build-system.scm
+++ b/guix/build/gnu-build-system.scm
@@ -303,7 +303,7 @@ makefiles."
(define (list-of-files dir)
(map (cut string-append dir "/" <>)
(or (scandir dir (lambda (f)
- (let ((s (stat (string-append dir "/" f))))
+ (let ((s (lstat (string-append dir "/" f))))
(eq? 'regular (stat:type s)))))
'())))