summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/text-editors.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index e0f07832f2..5b7f2e937c 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -727,7 +727,14 @@ in plain text file format.")
(lambda* (#:key inputs #:allow-other-keys)
(let ((tests (assoc-ref inputs "tests")))
(copy-recursively tests "tests"))
- #t)))))
+ #t))
+ (add-after 'install 'delete-static-library
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (lib (string-append out "/lib")))
+ (with-directory-excursion lib
+ (delete-file "libeditorconfig_static.a"))
+ #t))))))
(native-inputs
`(("tests"
,(origin