summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/games.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 4ab0af2e77..7896c9c3f4 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -2053,6 +2053,13 @@ This game is based on the GPL version of the famous game TuxRacer.")
"-DCMAKE_C_FLAGS=-fpermissive")
#:phases
(modify-phases %standard-phases
+ ;; see https://github.com/supertuxkart/stk-code/issues/3557
+ (add-after 'unpack 'patch-for-mesa-18.3
+ (lambda _
+ (substitute* "src/graphics/gl_headers.hpp"
+ (("#if !defined\\(USE_GLES2\\)")
+ "#if !defined(USE_GLES2)\n# define __gl_glext_h_"))
+ #t))
(add-after 'unpack 'unbundle
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "CMakeLists.txt"