summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/virtualization.scm8
1 files changed, 1 insertions, 7 deletions
diff --git a/gnu/packages/virtualization.scm b/gnu/packages/virtualization.scm
index 9f80e333be..4368949743 100644
--- a/gnu/packages/virtualization.scm
+++ b/gnu/packages/virtualization.scm
@@ -730,13 +730,7 @@ domains, their live performance and resource utilization statistics.")
(setenv "C_INCLUDE_PATH"
(string-append (assoc-ref inputs "libnl")
"/include/libnl3:"
- ;; Also add the kernel headers here so that GCC
- ;; treats them as "system headers". Otherwise
- ;; the build fails with -Werror because parasite.c
- ;; includes both <linux/fs.h> and <sys/mount.h>,
- ;; which define some of the same constants.
- (assoc-ref inputs "kernel-headers")
- "/include"))
+ (or (getenv "C_INCLUDE_PATH") "")))
#t))
(add-after 'configure 'fix-documentation
(lambda* (#:key inputs outputs #:allow-other-keys)