summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/audio.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 35b60511bc..4f76bded38 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -1509,6 +1509,15 @@ to be plugged into a wide range of audio synthesis and recording packages.")
(base32
"12z1vx3krrzsfccpah9xjs68900xvr7bw92wx8np5871i2yv47iw"))))
(build-system gnu-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ ;; lashd embeds an ancient version of sigsegv so we just skip it
+ (add-after 'unpack 'skip-lashd
+ (lambda _
+ (substitute* '("Makefile.am" "Makefile.in")
+ (("lashd ") ""))
+ #t)))))
(inputs
`(("bdb" ,bdb)
("gtk" ,gtk+-2)