summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/emacs.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index b3d5fc97e2..be89790344 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -5512,3 +5512,24 @@ Idris.")
github/gitlab (or bitbucket) by calling @code{browse-at-remote} command.
It supports dired buffers and opens them in tree mode at destination.")
(license license:gpl3+))))
+
+(define-public emacs-tiny
+ (package
+ (name "emacs-tiny")
+ (version "0.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://elpa.gnu.org/packages/tiny-" version ".tar"))
+ (sha256
+ (base32
+ "1nhg8375qdn457wj0xmfaj72s87xbabk2w1nl6q7rjvwxv08yyn7"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/abo-abo/tiny")
+ (synopsis "Quickly generate linear ranges in Emacs")
+ (description
+ "The main command of the @code{tiny} extension for Emacs is @code{tiny-expand}.
+It iss meant to quickly generate linear ranges, e.g. 5, 6, 7, 8. Some elisp
+proficiency is an advantage, since you can transform your numeric range with
+an elisp expression.")
+ (license license:gpl3+)))