summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/gl.scm6
-rw-r--r--gnu/packages/xorg.scm4
2 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 27d064346e..8494b48603 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -240,15 +240,15 @@ also known as DXTn or DXTC) for Mesa.")
"mesa-skip-disk-cache-test.patch"))))
(build-system gnu-build-system)
(propagated-inputs
- `(("glproto" ,glproto)
- ;; The following are in the Requires.private field of gl.pc.
+ `(;; The following are in the Requires.private field of gl.pc.
("libdrm" ,libdrm)
("libvdpau" ,libvdpau)
("libx11" ,libx11)
("libxdamage" ,libxdamage)
("libxfixes" ,libxfixes)
("libxshmfence" ,libxshmfence)
- ("libxxf86vm" ,libxxf86vm)))
+ ("libxxf86vm" ,libxxf86vm)
+ ("xorgproto" ,xorgproto)))
(inputs
`(("expat" ,expat)
("dri2proto" ,dri2proto)
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index cf062fd253..fade6e8fea 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -935,8 +935,8 @@ the fonts protocol.")
(description
"OpenGL Extension defines a protocol for the client to send 3D
rendering commands to the X server.")
- (license license:x11)))
-
+ (license license:x11)
+ (properties `((superseded . ,xorgproto)))))
(define-public iceauth
(package