summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu-system.am1
-rw-r--r--gnu/packages/patches/xf86-video-r128-glibc-2.20.patch17
-rw-r--r--gnu/packages/xorg.scm7
3 files changed, 22 insertions, 3 deletions
diff --git a/gnu-system.am b/gnu-system.am
index 105a8a213e..9673124083 100644
--- a/gnu-system.am
+++ b/gnu-system.am
@@ -469,6 +469,7 @@ dist_patch_DATA = \
gnu/packages/patches/xf86-video-mga-glibc-2.20.patch \
gnu/packages/patches/xf86-video-nv-remove-mibstore.patch \
gnu/packages/patches/xf86-video-openchrome-glibc-2.20.patch \
+ gnu/packages/patches/xf86-video-r128-glibc-2.20.patch \
gnu/packages/patches/xfce4-panel-plugins.patch \
gnu/packages/patches/xmodmap-asprintf.patch
diff --git a/gnu/packages/patches/xf86-video-r128-glibc-2.20.patch b/gnu/packages/patches/xf86-video-r128-glibc-2.20.patch
new file mode 100644
index 0000000000..21a430ebc6
--- /dev/null
+++ b/gnu/packages/patches/xf86-video-r128-glibc-2.20.patch
@@ -0,0 +1,17 @@
+Fix test compilation with exa.h in configure when using glibc 2.20.
+Inspired by a patch by Peter Hutterer <peter.hutterer@who-t.net>.
+See <https://raw.githubusercontent.com/openembedded/oe-core/master/meta/recipes-graphics/xorg-driver/xf86-input-synaptics/always_include_xorg_server.h.patch>.
+
+--- xf86-video-r128-6.9.2/configure.~1~ 2013-10-02 14:38:15.000000000 -0400
++++ xf86-video-r128-6.9.2/configure 2014-12-19 01:23:03.346735159 -0500
+@@ -18400,7 +18400,9 @@
+
+ SAVE_CPPFLAGS="$CPPFLAGS"
+ CPPFLAGS="$CPPFLAGS $XORG_CFLAGS"
+- ac_fn_c_check_header_mongrel "$LINENO" "exa.h" "ac_cv_header_exa_h" "$ac_includes_default"
++ ac_fn_c_check_header_mongrel "$LINENO" "exa.h" "ac_cv_header_exa_h" "$ac_includes_default
++#include <xorg-server.h>
++"
+ if test "x$ac_cv_header_exa_h" = xyes; then :
+ have_exa_h="yes"
+ else
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index d337c18c82..953e764dc5 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -2797,17 +2797,18 @@ kernel mode setting (KMS).")
(define-public xf86-video-r128
(package
(name "xf86-video-r128")
- (version "6.8.2")
+ (version "6.9.2")
(source
(origin
(method url-fetch)
(uri (string-append
- "mirror://xorg/X11R7.7/src/everything/xf86-video-r128-"
+ "mirror://xorg/individual/driver/xf86-video-r128-"
version
".tar.bz2"))
(sha256
(base32
- "1c84x40k9qz9dnf5qs6nnjcgz7px6mpc3rbk8mj62zhp7mf16hbv"))))
+ "1q3fsc603k2yinphx5rrcl5356qkpywwz8axlw277l2231gjjbcb"))
+ (patches (list (search-patch "xf86-video-r128-glibc-2.20.patch")))))
(build-system gnu-build-system)
(inputs `(("mesa" ,mesa)
("xf86driproto" ,xf86driproto)