summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/jami.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/jami.scm b/gnu/packages/jami.scm
index c2f65ee66a..85a06026ed 100644
--- a/gnu/packages/jami.scm
+++ b/gnu/packages/jami.scm
@@ -142,8 +142,10 @@
;; against pjproject-jami:
;; relocation R_X86_64_32S against `.rodata' can not be used when
;; making a shared object;
- "CFLAGS=-fPIC"
- "CXXFLAGS=-fPIC")
+ ;; -DNDEBUG is needed to prevent assertion from happening and
+ ;; stopping the daemon.
+ "CFLAGS=-fPIC -DNDEBUG"
+ "CXXFLAGS=-fPIC -DNDEBUG")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'make-git-checkout-writable