summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/gnome.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index fbd4c5eb96..fb8c8b9472 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -7828,7 +7828,11 @@ world.")
;; GNOME-Core-Utilities
("baobab" ,baobab)
("cheese" ,cheese)
- ("eog" ,eog)
+ ;; XXX: EoG requires librsvg-next, which depends on Rust, which currently
+ ;; only works on x86_64, so exclude it on other architectures.
+ ,@(if (string-prefix? "x86_64" (%current-system))
+ `(("eog" ,eog))
+ '())
("epiphany" ,epiphany)
("evince" ,evince)
("file-roller" ,file-roller)