summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/games.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 82a9660b2a..e8cb012fba 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -2745,6 +2745,14 @@ interface or via an external visual interface such as GNU XBoard.")
;; These tests require a graphical interface.
(substitute* "src/Makefile.am"
(("test_gfx_fonts TestIOGfxDisplay") ""))
+ #t))
+ (add-before 'bootstrap 'autoreconf
+ (lambda _
+ ;; automake is out of date in the source
+ ;; autoreconf updates the automake scripts
+ (invoke "autoreconf")
+ ;; Build fails when autom4te.cache exists.
+ (delete-file-recursively "autom4te.cache")
#t)))))
(native-inputs `(("autoconf" ,autoconf)
("automake" ,automake)