summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/base.scm17
1 files changed, 12 insertions, 5 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index a6663c5cf6..c8fd8624af 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -515,14 +515,22 @@ store.")
(define-public glibc/linux
(package
(name "glibc")
- (version "2.26")
+ ;; Glibc has stable branches that continuously pick fixes for each supported
+ ;; release. Unfortunately they do not do point-releases, so we are stuck
+ ;; with copying almost all patches, or use a snapshot of the release branch.
+ ;;
+ ;; This version number corresponds to the output of `git describe` and the
+ ;; archive can be generated by checking out the commit ID and running:
+ ;; git archive --prefix=$(git describe)/ HEAD | xz -9 > $(git describe).tar.xz
+ ;; See <https://bugs.gnu.org/29406> for details.
+ (version "2.26-91-gaaa2eb83b8")
(source (origin
(method url-fetch)
- (uri (string-append "mirror://gnu/glibc/glibc-"
- version ".tar.xz"))
+ (uri (string-append "https://alpha.gnu.org/gnu/guix/mirror/"
+ "glibc-" version ".tar.xz"))
(sha256
(base32
- "1ggnj1hzjym7sn93rbwydcqd562q73lsb7g7kd199g6j9j9hlkp5"))
+ "1zwz6d0x3ndd0hgqp17fx71miyjvn4dgkl1nzhaz3mbcqxzrprhk"))
(snippet
;; Disable 'ldconfig' and /etc/ld.so.cache. The latter is
;; required on LFS distros to avoid loading the distro's libc.so
@@ -533,7 +541,6 @@ store.")
(modules '((guix build utils)))
(patches (search-patches "glibc-ldd-x86_64.patch"
"glibc-versioned-locpath.patch"
- "glibc-CVE-2017-15670-15671.patch"
"glibc-o-largefile.patch"))))
(build-system gnu-build-system)