summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/maths.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 201fb9c970..e4e9c52598 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -3087,13 +3087,13 @@ underway to allow BLIS to select the right optimized kernels at run time:
(lambda* (#:key outputs #:allow-other-keys)
;; This is a home-made 'configure' script.
(let ((out (assoc-ref outputs "out")))
- (zero? (system* "./configure" "-p" out
- "-d" "opt"
- "--disable-static"
- "--enable-shared"
- "--enable-threading=openmp"
+ (invoke "./configure" "-p" out
+ "-d" "opt"
+ "--disable-static"
+ "--enable-shared"
+ "--enable-threading=openmp"
- ,implementation)))))
+ ,implementation))))
(add-before 'check 'show-test-output
(lambda _
;; By default "make check" is silent. Make it verbose.