summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/cran.scm23
-rw-r--r--gnu/packages/statistics.scm23
2 files changed, 23 insertions, 23 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index ebe9e861ce..dc181d435a 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -22143,3 +22143,26 @@ multi-state models.")
"This package creates scatterpie plots, especially useful for plotting
pies on a map.")
(license license:artistic2.0)))
+
+(define-public r-boruta
+ (package
+ (name "r-boruta")
+ (version "7.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "Boruta" version))
+ (sha256
+ (base32
+ "0y2w4wb45kfnzrxcrdsiwgal9fsnlr3wad1sqdc70qv8gp921xbg"))))
+ (properties `((upstream-name . "Boruta")))
+ (build-system r-build-system)
+ (propagated-inputs `(("r-ranger" ,r-ranger)))
+ (home-page "https://gitlab.com/mbq/Boruta/")
+ (synopsis "Wrapper algorithm for all relevant feature selection")
+ (description
+ "This package provides an all relevant feature selection wrapper
+algorithm. It finds relevant features by comparing original attributes'
+importance with importance achievable at random, estimated using their
+permuted copies (shadows).")
+ (license license:gpl2+)))
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 76a93db976..cc4e7ac4c8 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -5903,26 +5903,3 @@ Java package that provides routines for various statistical distributions.")
Emacs. It is designed to support editing of scripts and interaction with
various statistical analysis programs such as R, Julia, and JAGS.")
(license license:gpl2+)))
-
-(define-public r-boruta
- (package
- (name "r-boruta")
- (version "7.0.0")
- (source
- (origin
- (method url-fetch)
- (uri (cran-uri "Boruta" version))
- (sha256
- (base32
- "0y2w4wb45kfnzrxcrdsiwgal9fsnlr3wad1sqdc70qv8gp921xbg"))))
- (properties `((upstream-name . "Boruta")))
- (build-system r-build-system)
- (propagated-inputs `(("r-ranger" ,r-ranger)))
- (home-page "https://gitlab.com/mbq/Boruta/")
- (synopsis "Wrapper algorithm for all relevant feature selection")
- (description
- "This package provides an all relevant feature selection wrapper
-algorithm. It finds relevant features by comparing original attributes'
-importance with importance achievable at random, estimated using their
-permuted copies (shadows).")
- (license license:gpl2+)))