summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/algebra.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 93dc756147..fe039d82a5 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -42,6 +42,7 @@
#:use-module (gnu packages mpi)
#:use-module (gnu packages multiprecision)
#:use-module (gnu packages perl)
+ #:use-module (gnu packages pulseaudio)
#:use-module (gnu packages python)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages readline)
@@ -301,13 +302,16 @@ precision.")
(delete-file (string-append out "/bin/xcasnew"))
#t))))))
(inputs
+ ;;; TODO: Add libnauty.
`(("fltk" ,fltk)
+ ("glpk" ,glpk)
("gmp" ,gmp)
("gsl" ,gsl)
("lapack" ,lapack)
("libao" ,ao)
("libjpeg" ,libjpeg)
("libpng" ,libpng)
+ ("libsamplerate" ,libsamplerate)
("libx11" ,libx11)
("libxinerama" ,libxinerama)
("libxft" ,libxft)
@@ -320,7 +324,9 @@ precision.")
("pari-gp" ,pari-gp)
("tcsh" ,tcsh)))
(native-inputs
- `(("readline" ,readline)
+ `(("bison" ,bison)
+ ("flex" ,flex)
+ ("readline" ,readline)
("texlive" ,texlive-tiny)))
(home-page "https://www-fourier.ujf-grenoble.fr/~parisse/giac.html")
(synopsis "Computer algebra system")