summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/music.scm10
-rw-r--r--gnu/packages/patches/libmygpo-qt-fix-jsoncreatortest.patch41
3 files changed, 3 insertions, 49 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 0bdfc521c2..639dd943d6 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -860,7 +860,6 @@ dist_patch_DATA = \
%D%/packages/patches/libmad-armv7-thumb-pt2.patch \
%D%/packages/patches/libmad-frame-length.patch \
%D%/packages/patches/libmad-mips-newgcc.patch \
- %D%/packages/patches/libmygpo-qt-fix-jsoncreatortest.patch \
%D%/packages/patches/libsndfile-armhf-type-checks.patch \
%D%/packages/patches/libsndfile-CVE-2017-8361-8363-8365.patch \
%D%/packages/patches/libsndfile-CVE-2017-8362.patch \
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index bb98f5b6a1..aea7395d41 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -11,7 +11,7 @@
;;; Copyright © 2017 Nils Gillmann <ng0@n0.is>
;;; Copyright © 2017 Rodger Fox <thylakoid@openmailbox.org>
;;; Copyright © 2017, 2018 Nicolas Goaziou <mail@nicolasgoaziou.fr>
-;;; Copyright © 2017 Pierre Langlois <pierre.langlois@gmx.com>
+;;; Copyright © 2017, 2018 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 nee <nee.git@hidamari.blue>
@@ -3846,19 +3846,15 @@ by The Echo Nest.")
(define-public libmygpo-qt
(package
(name "libmygpo-qt")
- (version "1.0.9")
+ (version "1.1.0")
(source (origin
(method url-fetch)
(uri (string-append "http://stefan.derkits.at/files/"
"libmygpo-qt/libmygpo-qt." version ".tar.gz"))
(sha256
(base32
- "1wsgh2vjnd52rkvpncj1ycpbp84sj9hh12ija46b42z9mmqf2jm4"))
- (patches
- (search-patches "libmygpo-qt-fix-jsoncreatortest.patch"))))
+ "1kg18qrq2rsswgzhl65r3mlyx7kpqg4wwnbp4yiv6svvmadmlxl2"))))
(build-system cmake-build-system)
- (arguments
- '(#:configure-flags '("-DBUILD_WITH_QT4=OFF")))
(native-inputs
`(("pkg-config" ,pkg-config)))
(inputs
diff --git a/gnu/packages/patches/libmygpo-qt-fix-jsoncreatortest.patch b/gnu/packages/patches/libmygpo-qt-fix-jsoncreatortest.patch
deleted file mode 100644
index c457d592cc..0000000000
--- a/gnu/packages/patches/libmygpo-qt-fix-jsoncreatortest.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-From ebe2323727f8d646590245b0bf06dbc92b5808d6 Mon Sep 17 00:00:00 2001
-From: Golubev Alexander <fatzer2@gmail.com>
-Date: Tue, 20 Sep 2016 15:33:30 +0400
-Subject: [PATCH] JsonCreatorTest failed due to extra space
-
-JsonCreatorTest failed with next message:
-```
-********* Start testing of mygpo::JsonCreatorTest *********
-Config: Using QTest library 4.8.6, Qt 4.8.6
-PASS : mygpo::JsonCreatorTest::initTestCase()
-PASS : mygpo::JsonCreatorTest::testAddRemoveSubsToJSON()
-PASS : mygpo::JsonCreatorTest::testSaveSettingsToJSON()
-FAIL! : mygpo::JsonCreatorTest::testEpisodeActionListToJSON() Compared values are not the same
- Actual (outString2): [{"action":"download","device":"device1","episode":"http://episode.url","podcast":"http://podcast.url","timestamp":"1998-01-01T00:01:02"},{"action":"delete","device":"device3","episode":"http://episode2.url","podcast":"http://podcast2.url","timestamp":"1920-01-01T12:01:02"},{"action":"new","device":"foodev","episode":"http://www.podtrac.com","podcast":"http://leo.am","timestamp":"1998-01-01T00:01:02"},{"action":"play","device":"foodev","episode":"http://www.podtrac.com","podcast":"http://leo.am","timestamp":"1920-01-01T12:01:02"},{"action":"play","device":"foodev","episode":"http://www.podtrac.com","podcast":"http://leo.am","position":123,"started":10,"timestamp":"1998-01-01T00:01:02","total":321},{"action":"play","device":"foodev","episode":"http://www.podtrac.com","podcast":"http://leo.am","position":10,"timestamp":"1998-01-01T00:01:02"}]
- Expected (expected2): [{"action":"download","device":"device1","episode":"http://episode.url","podcast":"http:
- Loc: [/var/tmp/portage/media-libs/libmygpo-qt-1.0.9-r1/work/libmygpo-qt-1.0.9/tests/JsonCreatorTest.cpp(138)]
-PASS : mygpo::JsonCreatorTest::testRenameDeviceStringToJSON()
-PASS : mygpo::JsonCreatorTest::testDeviceSynchronizationListsToJSON()
-PASS : mygpo::JsonCreatorTest::cleanupTestCase()
-Totals: 6 passed, 1 failed, 0 skipped
-********* Finished testing of mygpo::JsonCreatorTest *********
-```
-
-This was caused by extra space in the expected string.
----
- tests/JsonCreatorTest.cpp | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/tests/JsonCreatorTest.cpp b/tests/JsonCreatorTest.cpp
-index b15b006..feb03d5 100644
---- a/tests/JsonCreatorTest.cpp
-+++ b/tests/JsonCreatorTest.cpp
-@@ -133,7 +133,7 @@ void JsonCreatorTest::testEpisodeActionListToJSON()
-
- output = JsonCreator::episodeActionListToJSON(episodeActions);
- QString outString2 = QString::fromLatin1( output ).replace( QLatin1String(" "), QLatin1String("") );
-- QString expected2( QLatin1String( "[{\"action\":\"download\",\"device\":\"device1\",\"episode\":\"http://episode.url\",\"podcast\":\"http://podcast.url\",\"timestamp\":\"1998-01-01T00:01:02\"},{\"action\":\"delete\",\"device\":\"device3\",\"episode\":\"http://episode2.url\",\"podcast\":\"http://podcast2.url\",\"timestamp\":\"1920-01-01T12:01:02\"},{\"action\":\"new\",\"device\":\"foodev\",\"episode\":\"http://www.podtrac.com\",\"podcast\":\"http://leo.am\",\"timestamp\":\"1998-01-01T00:01:02\"},{\"action\":\"play\",\"device\":\"foodev\",\"episode\":\"http://www.podtrac.com\",\"podcast\":\"http://leo.am\",\"timestamp\":\"1920-01-01T12:01:02\" },{\"action\":\"play\",\"device\":\"foodev\",\"episode\":\"http://www.podtrac.com\",\"podcast\":\"http://leo.am\",\"position\":123,\"started\":10,\"timestamp\":\"1998-01-01T00:01:02\",\"total\":321},{\"action\":\"play\",\"device\":\"foodev\",\"episode\":\"http://www.podtrac.com\",\"podcast\":\"http://leo.am\",\"position\":10,\"timestamp\":\"1998-01-01T00:01:02\"}]" ) );
-+ QString expected2( QLatin1String( "[{\"action\":\"download\",\"device\":\"device1\",\"episode\":\"http://episode.url\",\"podcast\":\"http://podcast.url\",\"timestamp\":\"1998-01-01T00:01:02\"},{\"action\":\"delete\",\"device\":\"device3\",\"episode\":\"http://episode2.url\",\"podcast\":\"http://podcast2.url\",\"timestamp\":\"1920-01-01T12:01:02\"},{\"action\":\"new\",\"device\":\"foodev\",\"episode\":\"http://www.podtrac.com\",\"podcast\":\"http://leo.am\",\"timestamp\":\"1998-01-01T00:01:02\"},{\"action\":\"play\",\"device\":\"foodev\",\"episode\":\"http://www.podtrac.com\",\"podcast\":\"http://leo.am\",\"timestamp\":\"1920-01-01T12:01:02\"},{\"action\":\"play\",\"device\":\"foodev\",\"episode\":\"http://www.podtrac.com\",\"podcast\":\"http://leo.am\",\"position\":123,\"started\":10,\"timestamp\":\"1998-01-01T00:01:02\",\"total\":321},{\"action\":\"play\",\"device\":\"foodev\",\"episode\":\"http://www.podtrac.com\",\"podcast\":\"http://leo.am\",\"position\":10,\"timestamp\":\"1998-01-01T00:01:02\"}]" ) );
-
- QCOMPARE(outString2, expected2 );
- }